gdelgado
Contributor
Contributor

Restarted Management Agents VM Showing Off

I am having an issue were when I restart the Management Agents on an ESXi 4.1 host some VM's are showing as Off even though there On and accessible. Also what I tried to do was to shutdown one of these VM's from a RDP session then power it back on using the VSphere Client when I try that it stops at 95% with an error but the VM does power on and I can access it. Has anyone encountered a similar issue?

Thanks..

0 Kudos
7 Replies
Troy_Clavell
Immortal
Immortal

they are showing as off, or disconnected. As part of restarting the management agents, hostd is restarted as well, and this is why you see disconnected. However the host(s) and guest(s) return to normal inventory views shortly after the agents have restarted.

0 Kudos
gdelgado
Contributor
Contributor

How long does it normally take as I did this about 30 minutes ago.

0 Kudos
Troy_Clavell
Immortal
Immortal

is this ESXi Host being managed by vCenter? A typical restart of the agents shouldn't take more than a minute or two before you can see the host and it's guest(s) back in inventory.

0 Kudos
gdelgado
Contributor
Contributor

This is a different issue then as it has been over 30 minutes and some clients are still showing as off. I am not using Vcenter I am using the Vsphere client connecting directly to the ESXi host.

Thanks..

0 Kudos
Troy_Clavell
Immortal
Immortal

hostd may have crashed, but i'm unsure in ESXi, how to query it. If hostd crashed, you may have to reboot the ESXi Host. However, have you tried to restart the management agents again?

0 Kudos
gdelgado
Contributor
Contributor

Looks like the 2nd restart did the trick after that I had 2 machines showing up as "invalid" I removed them from the inventory and then re-added them. 1 VM showed properly as On the other VM was still showing as powered off. I had to RDP to the one showing as Off shut it down from the RDP session and powered it back on from the VSphere Client. Now all VM's are displaying properly thank you Troy for your help on this.

Thanks..

0 Kudos
Troy_Clavell
Immortal
Immortal

glad to see you got it resolved

0 Kudos