Contributor
Contributor

Removing an orphaned NFS share

Jump to solution

Hey guys,

I have a standalone ESXi 6.5.0 U1 (HPE image) that is connected to a FreeNAS NFS share. It was previously connected to a Synology box also thru NFS. They both sit on the same IP.

Now, I keep getting messages every few seconds from ESXi /var/log/vmkwarning.log :

2018-02-01T14:47:51.571Z cpu0:66062)WARNING: NFS: 221: Got error 13 from mount call

and FreeNAS:

Feb 1 18:48:51 freenas mountd[1891]: mount request denied from 192.168.1.200 for /volume1

Feb 1 18:49:21 freenas mountd[1891]: mount request from 192.168.1.200 for non existent path /volume1

From this, it looks like my ESXi is trying to connect to a NFS share on the old Synology box which is nonexistent. On my ESXi GUI I can't seem to find any mention of this orphaned share. I have tried to find it thru all the possible cli commands (esxcli storage nfs list, etc) but no entries there.

I have even tried to simulate the old Synology and remount that share however not much luck.

Any help other than changing my FreeNAS IP or reinstalling ESXi.

Thanks

Tags (4)
1 Solution

Accepted Solutions
Contributor
Contributor

I found a solution from a fellow redditor. The old entry of that NFS share was only in /etc/vmware/esx.conf. Once I removed it from there and applied those settings everything was sorted. Funny enough it did not show anywhere else.

View solution in original post

2 Replies
VMware Employee
VMware Employee

Hello vgracanin

Does it still show up when you run this?:

# esxcli storage nfs list

Try manually removing it:

# esxcli storage nfs remove -v NFS_Volume_Name

You could also do as a.p. advised here to recreate the mountpoint/share so that you can remove it properly:

https://communities.vmware.com/thread/548726

Bob

0 Kudos
Contributor
Contributor

I found a solution from a fellow redditor. The old entry of that NFS share was only in /etc/vmware/esx.conf. Once I removed it from there and applied those settings everything was sorted. Funny enough it did not show anywhere else.

View solution in original post