VMware Cloud Community
godbucket
Enthusiast
Enthusiast

Remove "Safely Remove Hardware" icon in a Windows guest

(I already posted this in another discussion but it was so burried down in the thread I fear no one will see it. Plus the discussion topic had nothing to do with this issue really. So there's my formal apology.)

I had lots of VM's that were migrated over from Hyper-V and legacy ESX 3.5 hosts. Upon booting into the ESXi 4.0 environment, the Network Adapters/NIC's showed up in the "Safely Remove Hardware" icon in Windows Server 2003.

Though VMware Support said this is "by design", this is actually really bad for us, because we host hundreds of Citrix and Terminal Servers, so we didnt want users with elevated rights disabling the NIC of the server they are on!

Solution: with VM powered off, go to Edit Settings, click Options tab at top, click on General, then click the Configuration Parameters button. Scroll all the way down to the bottom of the list and click Add Row. Type "devices.hotplug" without the quotations, and in the next field type "FALSE" without quotations. Power on VM and the "Safely Remove Hardware" icon is gone.

I know this may be double-rhetorical for the many ubergurus in these forums, but I want to add that I had this behavior not only with the VMXNET3 adapter but the others as well (E1000 and Flexible). Didnt seem to matter which flavor NIC, many VM's had this issue however.

Hope this helps someone! It would have saved me hours of research and troubleshooting on the phone with VMware Support.

Thanks!

Reply
0 Kudos
4 Replies
Batesit
Contributor
Contributor

Thank you for posting this!! yes...you saved me alot of research (took me 5 minutes to find your post and the solution to my problem...so i just wanted to say thank you for posting it!

Reply
0 Kudos
ForemanNZ
Enthusiast
Enthusiast

THANK YOU THANK YOU THANK YOU!

I'm just building a Windows 7 image, gave it a test, and I could remove the network adapter from the guest!  I added this setting and the whole "safely remove hardware" option is gone, which was my preference!

Reply
0 Kudos
mharris1984
Contributor
Contributor

Thank you!!!! !Thank you!!!!! Thank you!!!!! Thank you!!!!!

I've been looking for this for two years and finally stumbled on your post!!

Works for Windows XP/7/8!  ESX 5.0 View 5.2

Reply
0 Kudos
evris
Contributor
Contributor

Thank you a million times.

This issue was bugging me for some time now.

Reply
0 Kudos