rogermccarrick
Contributor
Contributor

Remode Tech Support Mode Warning

Jump to solution

Hosts built with ESXi 4.1

Vsphere 4.1

HA cluster

I turn on SSH or "Remote Tech Support Mode" and I get a warning in vsphere saying "Remode Tech Support on host has been enabled" and a yellow warning triangle on the host that I can't acknowledge or dismiss (

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=101620...)

I only want to see yellow or red for the things I don't want, but not for something that I do want! After all this stuff is extremely expensive so I dont know why VMware tell us we cannot get rid of this warning.

Anyone able to get rid of this warning?

thanks

Roger

0 Kudos
1 Solution

Accepted Solutions
Dave_Mishchenko
Immortal
Immortal

There's a bit of a work around on this thread - http://communities.vmware.com/message/1677306#1677306. You might want to submit a product suggestion for this if you really want it.

View solution in original post

0 Kudos
13 Replies
idle-jam
Immortal
Immortal

nope there is no other way.

0 Kudos
dquintana
Virtuoso
Virtuoso

Another point of view

Maybe i think that you really dont want to have the ssh enabled all the time because this could be a security issue. Think that , you havent a fw in the esxi, maybe this warning can seriouly to help you to detect an anormal access situation in hour host.

Diego

Ing. Diego Quintana - VMware Communities Moderator - Co Founder & CEO at Wetcom Group - vEXPERT From 2010 to 2020- VCP, VSP, VTSP, VAC - Twitter: @daquintana - Blog: http://www.wetcom.com-blog & http://www.diegoquintana.net - Enjoy the vmware communities !!!

0 Kudos
Dave_Mishchenko
Immortal
Immortal

There's a bit of a work around on this thread - http://communities.vmware.com/message/1677306#1677306. You might want to submit a product suggestion for this if you really want it.

View solution in original post

0 Kudos
samansalehi
Enthusiast
Enthusiast

Dear Friend;

For warning of remote tech support mode, it is better to know it's a important issue for security, it is the path to your host, it is unsafe and insecure, So it is better to turn off the SSH Enable and Remote Enable rather than have problem with warning.

On the other hand, some warnings like using maximum RAM, will turn off when the peak goes.

For alert, you can change the definitions if they are bothering u, that i don't recommend to do that, just, read the alert, and find the solution, or if it happened once, just mark it as acknowledge and back it to green with two times "right Click"

if this is useful, would u please mark it "helpful" or "correct"?

Thank u

Saman

0 Kudos
rogermccarrick
Contributor
Contributor

We are indeed in a cloud environment and it's not a case of forgetting that SSH is enable, it's or policy that it should be enabled.

So for us the correct answer is to put the host in maintenance mode and reboot.

This worked. In fact in another cluster this was working on other similar hosts and I didn't know why.

Now I do.

Thanks

0 Kudos
mal_michael
Commander
Commander

Hi,

You can open an iLO (or other similar remote management) and run "Restart Management Agents" under "Troubleshooting Options".

Does not require maintenance mode and reboot. Works for me on ESXi 4.1.

Michael.

0 Kudos
GTSI_Jim
Contributor
Contributor

Folks,

Thanks for the thread.  Same problem here in Texas (ESXi) and indeed a reboot got rid of the yellow triangle and warning message.

We are fine with remote SSH being enabled and in fact, need it for our backup solution.

Thanks to all,


jim

0 Kudos
lamw
Community Manager
Community Manager

A reboot will remove the TSM warning, but you actually don't have to reboot to get rid of it. You just need to restart hostd process as documented by Eric here - http://www.vcritical.com/2011/02/get-rid-of-those-esxi-tech-support-mode-warnings/

0 Kudos
Josh26
Virtuoso
Virtuoso

GTSI_Jim wrote:

We are fine with remote SSH being enabled and in fact, need it for our backup solution.

Thanks to all,


jim

Personally I would reconsider that backup solution.

0 Kudos
briwag
Enthusiast
Enthusiast

I had the same problem, wanted it to look clean but had the warning icon. Didn;t want to go through a reboot so I got around it by logging into the console with Putty and executing:

/etc/init.d/hostd restart

It appread to disconnect my guests in vCenter for a few seconds, but they came back online without any problems. For my other Hosts I migrated the VMs off first just to make sure nothing went crazy.

0 Kudos
gatekeep
Contributor
Contributor

Another method (that works for the Remote SSH mode) is the old method to enable SSH on ESXi 4.0, it is exactly the same, however, vSphere throws no warning that SSH is running. Here is the old procedure (with steps to ease configuration in 4.1):

  1. Enable Remote SSH via vSphere Client or the DCUI
  2. SSH to the machine
  3. While SSHed stop the Remote SSH service via vSphere Client or DCUI (this at least in my case did not kill my running SSH session)
  4. vi /etc/inetd.conf
    1. Remove the # from the front of the line that reads:
      ssh      stream   tcp   nowait   root   /sbin/dropbearmulti   dropbear ++min=0,swap,group=shell -i -K60
  5. After do ps | grep inetd and get the process ID
    1. (ex)
      ~ # ps | inetd
      4876 4876 busybox              inetd
      ~ # kill -HUP 4876
    2. Here you see from the "ps | grep inetd" that hte process ID for inetd is 4876. We run the "kill -HUP" to restart the inetd process.

  6. At this stage the vSphere Client will report "Remote SSH" as Stopped. You can verify using PuTTY or other SSH program that SSH is silently running.

This procedure *IS* utterly unsupported by VMware, I'm quite sure.

0 Kudos
vmjellz
Contributor
Contributor

Another option is to disable the warning from the advanced host software settings. I found instructions here:

http://vm-pro.com/remove-vmware-host-warning-for-local-tech-support-mode-and-remote-tech-support-mod...

Hope this helps!

0 Kudos
briwag
Enthusiast
Enthusiast

I will be out of the office from Wednesday, November 30th through Monday, December 5th. If you need immediate assistance please contact Adam Hughes.

Thank you,

Brian Wagner

Hosted Services Engineer

www.ThriveNetworks.com

0 Kudos