ThunFan06
Contributor
Contributor

Re: No DHCP for physical clients

Jump to solution

@abeggled

No there shouldn't be a router there. More information in the visio below...

Visio of the network (should be correct)

http://www.bilder-space.de/show.php?file=04.08AGPMCjdKIqeKjF1.jpg

Network configuration of the ESXi

If you need more information, just ask Smiley Wink

0 Kudos
1 Solution

Accepted Solutions
dab
Enthusiast
Enthusiast

Since the new DHCP-Server is just a replacment for the old one, can this be a problem outside virtualization?

Have you checked your switch about DHCP Snooping settings or IP/MAC based ACL's?

Daniel

---

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful

View solution in original post

0 Kudos
11 Replies

Does you router filter DHCP?


---

VMware vExpert '2009

http://blog.vadmin.ru

EMCCAe, MCITP: SA+VA, VCP 3/4/5, VMware vExpert http://blog.vadmin.ru
0 Kudos
ThunFan06
Contributor
Contributor

I don't think that, till this year, we used a physical server with dhcp and everything worked fine...

But thanks for your effort :smileygrin:

0 Kudos

Do you use VLANs in your network? Was physical DHCP in the same VLAN as virtual?

I have virtual DHCP and everything is fine.


---

VMware vExpert '2009

http://blog.vadmin.ru

EMCCAe, MCITP: SA+VA, VCP 3/4/5, VMware vExpert http://blog.vadmin.ru
0 Kudos
ThunFan06
Contributor
Contributor

I don't know much about the switch, which is ued, because we don't have access to it. The new virtual server took the place of the earlier physical one, which provided the DHCP, so it is probably the same VLAN

How did you configure your server. Did you anything special about the networking? Thanks in advance

0 Kudos
dab
Enthusiast
Enthusiast

How is your network setup?

Is there a router between the ESX, the DHCP-Server and the Clients? If so, have a look at configuring "ip helper-address" which tells the router to transport DHCP requests to the DHCP-Server on a different network or vlan ...

Was the physical server in the same subnet or vlan? Did you a P2V?

Daniel

---

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful

0 Kudos

No, nothing special in my networking setup.

Could you post screenshot of your ESXi network config?


---

VMware vExpert '2009

http://blog.vadmin.ru

EMCCAe, MCITP: SA+VA, VCP 3/4/5, VMware vExpert http://blog.vadmin.ru
0 Kudos
ThunFan06
Contributor
Contributor

http://www.bilder-space.de/show.php?file=04.08AGPMCjdKIqeKjF1.jpg

Configuration of the network in ESXi

@abeggled

No there there should't be something like this...

0 Kudos

Try this:

1. Open vSwitch properties

2. Select Virtual Machine Network, press Edit

3. Select NIC Teaming tab

4. Make vmnic1 active, vmnic0 unused

5. Press Ok


---

VMware vExpert '2009

http://blog.vadmin.ru

EMCCAe, MCITP: SA+VA, VCP 3/4/5, VMware vExpert http://blog.vadmin.ru
dab
Enthusiast
Enthusiast

Is the DHCP Server on the PDC aka DC or on the service server?

For which Subnet is the DHCP-Server issuing addresses?

Daniel

---

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful

ThunFan06
Contributor
Contributor

It's on the PDC. I was planning to have wds in action, but without DHCP on clients (PXE-Boot) this won't work

It's 192.168.1.X network. I made a scope from 192.168.1.101 - 135.

0 Kudos
dab
Enthusiast
Enthusiast

Since the new DHCP-Server is just a replacment for the old one, can this be a problem outside virtualization?

Have you checked your switch about DHCP Snooping settings or IP/MAC based ACL's?

Daniel

---

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful

0 Kudos