VMware Cloud Community
wobbe98
Enthusiast
Enthusiast

RHEL 6 Beta on ESXi4

The Beta for RHEL6 was just released. Anyone tried it on ESXi4 yet? Any caveats I should be aware of?'

I intend to test it myself tomorrow. With a bit of luck it will be a slow day at the office Smiley Happy

(TIP: You can force luck by locking the door to your office and ripping out the telephone)

Reply
0 Kudos
2 Replies
wobbe98
Enthusiast
Enthusiast

Mmm, it works.

Although I didn't get an ip address using the flexible NIC. But E1000 works fine.

Can't logon as root to the graphical console and that sucks!!

Reply
0 Kudos
mhanby
Contributor
Contributor

I just installed it and cannot get the VMware tools to install completely.

I've made sure to "yum groupinstall 'Development tools' " and it still is failing

I attached the full vmware-config-tools.pl log and here's an example of the error:

/tmp/vmware-config19/vmxnet-only/vmxnet.c: In function ‘vmxnet_set_multicast_list’:
/tmp/vmware-config19/vmxnet-only/vmxnet.c:2411: error: ‘struct net_device’ has no member named ‘priv’
/tmp/vmware-config19/vmxnet-only/vmxnet.c: In function ‘vmxnet_get_stats’:
/tmp/vmware-config19/vmxnet-only/vmxnet.c:2491: error: ‘struct net_device’ has no member named ‘priv’
make[2]: *** [/tmp/vmware-config19/vmxnet-only/vmxnet.o] Error 1
make[1]: *** [_module_/tmp/vmware-config19/vmxnet-only] Error 2
make[1]: Leaving directory `/usr/src/kernels/2.6.32-19.el6.x86_64'
make: *** [http://vmxnet.ko|http://vmxnet.ko] Error 2
make: Leaving directory `/tmp/vmware-config19/vmxnet-only'
Unable to build the vmxnet module.

I should follow by saying that vSphere Client reports "VMware Tools: OK" and that the E1000 network card works before and after installing the VMware tools.

Reply
0 Kudos