VMware Cloud Community
Simon_Momutech
Contributor
Contributor

Question around CPU Base Frequency

Hi,

I have set up a new ESXi 7 server and notice that my VMs under this server are reporting an incorrect CPU Base Frequency.  My server is running 2 Intel Xeon Gold 6242 CPU @ 2.80Ghz, however, Geekbench is telling me that my VM's CPU Base Frequency is only 1.39Ghz.

I have already disabled the Power Management Settings in BIOS, any other settings I could have missed?

Simon

Reply
0 Kudos
4 Replies
jsm79
Enthusiast
Enthusiast

Have you tried changing the power management settings in the host client? Not sure it can be done from vSphere, but in the host client, it's under Host  -> Manage -> Hardware tab -> Power Management. Change the policy to "High performance".

Reply
0 Kudos
Simon_Momutech
Contributor
Contributor

Changed to High Performance but it's the same.  I Ran Geekbench 6 and still scored 740 on a single core.

Reply
0 Kudos
hadjer1
Enthusiast
Enthusiast

Hello,

I'm not sure about this, but could it be because of hyperthreading is enabled on the host ?

Tags (1)
Reply
0 Kudos
Tibmeister
Expert
Expert

Definitely need to check out any additional power/frequency settings that may be present in the BIOS/EFI.  Also, once setting the hypervisor to Max Performance, you do need to reboot.

Some other things to consider and look into.  Do you have CPU/Memory HotAdd enabled?  Do you have 1 socket per core configured?  How many vCPU's to you have configured to the VM?  Do you have CPU Ready or CoStop on the host?

There's a number of reasons why a vCPU may not have access to the full frequency of a pCPU, and in most cases this is just fine due to the abstraction and how things work in the hypervisor.

 

Tags (1)
Reply
0 Kudos