VMware Cloud Community

Puzzler: After upgrade to ESXi 5.5, 10G NIC not recognized on one server but IS recognized on an identical server

Hi All -

We've got some IBM HS21 blades (machine type 8853) that I don't have the budget to part with yet.  They're not officially supported by ESXi 5.5, but they're fully loaded with RAM and have broadcom 10G NICs (BCM57710), so they're still completely serviceable.  They've been running ESX 4.1 for several years, but I've been slowly upgrading everything to ESXi 5.5, and it came time to upgrade the HS21s.

One of them upgraded from ESX 4.1 U3 to ESXi 5.5 U2 with no problems.  I'm actually running my main vCenter server on it right now.  However, two others that I've tried to upgrade are not able to recognize the 10G NIC after the upgrade.  I tried a clean install on both of them.  No good.  I also tried installing ESXi 5.1 U3, but that didn't work, either.  The only thing I've found that makes them work is downgrading to ESXi 4.1 U3, but I don't want to use this as I'd like to migrate all our storage to VMFS 5. 

Some really odd info:  On the non-working server I can see the devices with lspci, and they have a "vmnic" name.  I can also see them with ethtool, and they show a valid driver (bnx2x).  But they're not in the ESX NIC list (esxcfg-nics -l).  (See attached screenshot).

I tried editing /etc/vmware/esx.conf directly and adding them in this section:

/net/pnic/child[0001]/mac = "00:1a:64:d1:3f:16"

/net/pnic/child[0001]/virtualMac = "00:50:56:51:3f:16"

/net/pnic/child[0001]/name = "vmnic1"

/net/pnic/child[0001]/duplex = "auto"

/net/pnic/child[0001]/speed = "auto"

/net/pnic/child[0004]/mac = "00:14:5e:e5:2e:9a"

/net/pnic/child[0004]/virtualMac = "00:50:56:55:2e:9a"

/net/pnic/child[0004]/name = "vmnic4"

/net/pnic/child[0004]/duplex = "auto"

/net/pnic/child[0004]/speed = "auto"

/net/pnic/child[0003]/mac = "00:14:5e:a8:67:6f"

/net/pnic/child[0003]/virtualMac = "00:50:56:58:67:6f"

/net/pnic/child[0003]/name = "vmnic3"

/net/pnic/child[0003]/duplex = "auto"

/net/pnic/child[0003]/speed = "auto"

But they still don't show after a reboot.

The HS21 blade server on which these NICs are working is identical in all ways.  It's the same machine type and model, and the same firmware revisions on ALL the components.

Anyone have any ideas on how I can troubleshoot this?  I'm surely missing something obvious.


0 Kudos
1 Reply


0 Kudos