alternize
Contributor
Contributor

Problems getting Intel Ethernet Controller X540-AT2 to consistently auto-negotiate 1Gb portspeed

Jump to solution

I am setting up ESXi 6U1 on three Supermicro SYS-6018R-WTRT servers that come with the Intel Ethernet Controller X540-AT2 nic. unfortunately, the auto-negotiated port speed is changing between 1000 Mb and 100 Mb, seemingly randomly. sometimes, both vmnic adapters are recognized as 1000 Mb, sometimes one is 1000 Mb and one at 100 Mb, sometimes both are 100 Mb. the switch (Extreme Networks Summit X350-48T) works fine for other gbit servers, tho the supermicro servers are the first one with 10Gb cards.

ESXi is at the latest patch level with the additional ixgbe driver vib v4.1.11 installed:

[root@endor1:~] esxcli software vib list | grep ixgbe

net-ixgbe                      4.1.1.1-1OEM.550.0.0.1331820         Intel   VMwareCertified   2015-12-15

when manualy disabling/enabling the port on the switch, dmesg on esxi shows:

2015-12-17T14:47:25.871Z cpu8:33247)<6>ixgbe 0000:01:00.1: vmnic1: NIC Link is Down

2015-12-17T14:47:25.871Z cpu8:33247)<3>ixgbe: vmnic1: ixgbe_watchdog_link_is_down: NIC CNA Link is Down

2015-12-17T14:48:29.571Z cpu14:33243)<6>ixgbe 0000:01:00.1: vmnic1: NIC Link is Up 100 Mbps, Flow Control: RX/TX

2015-12-17T14:48:29.571Z cpu14:33243)<3>ixgbe: vmnic1: ixgbe_watchdog_link_is_up: NIC CNA Link is Up

2015-12-17T14:48:29.905Z cpu11:32854)NetPort: 1780: disabled port 0x2000005

2015-12-17T14:48:29.905Z cpu11:32854)Uplink: 7316: enabled port 0x2000005 with mac 00:25:90:f9:75:f3

any hints are very much appreciated.

0 Kudos
1 Solution

Accepted Solutions
alternize
Contributor
Contributor

the Extreme Networks Summit X350-48 seems incompatible with the 10GE cards. swapped the switch for a Brocade FLS 648 and everything works just fine.

View solution in original post

0 Kudos
1 Reply
alternize
Contributor
Contributor

the Extreme Networks Summit X350-48 seems incompatible with the 10GE cards. swapped the switch for a Brocade FLS 648 and everything works just fine.

0 Kudos