svelosov
Contributor
Contributor

Problem USB device VMware ESXi 4.0.0 - 4.1.0

Jump to solution

Dear,

I have a problem for my server to recognize USB devices.
VMware ESXi is installed 4.0.0 and 4.1.0 and in both cases these devices do notrecognize me.
The machines I tested on Windows Server 2003, 2008 and even Linux and there is nocase.

Any solution or idea?

Best regards

Sebastián

0 Kudos
1 Solution

Accepted Solutions
Bosvark
Contributor
Contributor

I had the same problem. You will also notice that there is no power to the usb device

Look at these two links:

http://www.vm-help.com/esx40i/VMDirectPath/fix_config_issues.php

http://www.vm-help.com/esx40i/VMDirectPath/USB_Setup.php

NB NB NB: the host chipset must support the option of passthrough

After adding all my usb devices, and after a restart, my local host console was frozen and i could not access anything. I did a repair and that quickly got everything up and running, and will now add each device for passthrough one by one. (u have to restart the host after addind the devices)

Helpfile for above problem:

http://www.vm-help.com/forum/viewtopic.php?f=22&t=2603

View solution in original post

0 Kudos
20 Replies
athlon_crazy
Virtuoso
Virtuoso

After you add usb controller to the VM, have you able to pick usb device in VM edit setting?

You can start with this KB about USB support for ESX/ESXi and this KB for supported USB device.

http://www.no-x.org
0 Kudos
AndreTheGiant
Immortal
Immortal

Only 4.1 has a working USB (server side) support.

Add the USB controller.

Then you must see the USB device and you can add them.

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
0 Kudos
idle-jam
Immortal
Immortal

for USB passthrough you will need vSphere 4.1. Here are the steps: http://vstorage.wordpress.com/2010/07/15/usb-passthrough-in-vsphere-4-1/

0 Kudos
svelosov
Contributor
Contributor

Dear, still can not make me recognize my USB devices.
As information, my license to VMware ESXi 4 is free and has all the functionality, canbe such a restriction?

0 Kudos
mikelane
Expert
Expert

I am using the free version of vSphere 4.1 (ESXi) and the USB is working fine for me - it is not a restriction with the free version.

0 Kudos
DSTAVERT
Immortal
Immortal

mikelane

Could you add anything from your experience that might help the original poster. What example you might have followed. Any details that might be especially important.

Thanks

-- David -- VMware Communities Moderator
0 Kudos
mikelane
Expert
Expert

All I can add is my own blog post on the subject (which I will happily do).

I didn't add it initially as I don't think that it added anything to the discussion:

http://pricklytech.wordpress.com/2010/07/16/vmware-vsphere-4-1-usb-pass-through/

A key point is that once you have added the USB Controller to the virtual machine not all USB devices are supported - so it will depend on what device(s) you are trying to use. If it is not supported you may be out of luck ...

Hope that it helps!

0 Kudos
svelosov
Contributor
Contributor

I followed the instructions I have given and can not get me recognize my USB devices.

I added to the discussion a document with pictures of my ESXi server

Best regards

0 Kudos
mikelane
Expert
Expert

What USB devices are you trying to add? vSphere doesn't support every kind of USB device ...

0 Kudos
svelosov
Contributor
Contributor

Hi Mike,

I've tried 2 flash drive: the first is a common pendrive 2 GB and the other a 16 GBKingston DataTraveler

Best regards

0 Kudos
mikelane
Expert
Expert

I'm not clear so far at what point you are having issues.

Are you seeing the jump drives as devices that you can assign to a particular virtual machine (as per screenshot below)?:

http://pricklytech.files.wordpress.com/2010/07/vsphere-select-usb-device.png?w=640&h=502

As you can see in the screen above I have a DataTraveller jump drive marked as Available to add to a virtual machine. The other jump drive is already assigned to a virtual machine (vm-whs).

0 Kudos
svelosov
Contributor
Contributor
Thanks for responding Mike,

See you attach a document with step by step I take to add a USB device in a virtualmachine

When you add, I did not recognize my Kingston DataTraveler

What is this?

Best regards

0 Kudos
mikelane
Expert
Expert

In your vmware_usb2.pdf you have successfully added a USB controller to the virtual machine.

You need to click the "Add" button again and then select "USB Device" to add a device.

Please post screens of this process in your next post.

0 Kudos
svelosov
Contributor
Contributor

Mike,

Attached image that appears after you add a USB controller.

Thanks!

Best regards

0 Kudos
idle-jam
Immortal
Immortal

can you replug the usb device to another usb port and try to go to that screen again? by right you should see usb device ..

0 Kudos
DSTAVERT
Immortal
Immortal

Thankfully the evening shift has arrived. Good evening.:smileycool:

-- David -- VMware Communities Moderator
0 Kudos
svelosov
Contributor
Contributor

Thank you all,

Tomorrow I will try connecting to the USB flash drive back to my server.

Also, I will implement a new ESXi 4.0 server an HP DL-360 G6 again.

When you install VMware ESXi 4.0 Is it necessary to enable any additional functionality for USB devices that work?

We are in contact

0 Kudos
svelosov
Contributor
Contributor

Hello everyone,

I just changed the flash drive Kingston DataTraveler USB rear connectors on the serverand I do not recognize the device.

Any ideas for this?

0 Kudos
Bosvark
Contributor
Contributor

I had the same problem. You will also notice that there is no power to the usb device

Look at these two links:

http://www.vm-help.com/esx40i/VMDirectPath/fix_config_issues.php

http://www.vm-help.com/esx40i/VMDirectPath/USB_Setup.php

NB NB NB: the host chipset must support the option of passthrough

After adding all my usb devices, and after a restart, my local host console was frozen and i could not access anything. I did a repair and that quickly got everything up and running, and will now add each device for passthrough one by one. (u have to restart the host after addind the devices)

Helpfile for above problem:

http://www.vm-help.com/forum/viewtopic.php?f=22&t=2603

View solution in original post

0 Kudos