SoloCon
Contributor
Contributor

Please help - Esxi Losing data-storage and VM's when enabling USB 3 pass-through

Hello,

I'm very new to esxi and trying to my usb3 passthrough to work. Every time I enable the onboard usb3 headers for passthrough and reset the system to take effect, I end up losing my data storage and my VM's and have to reinstall esxi. I've been hitting my head on this for almost a week.

Here my setup:

ASUS ROG STRIX X399-E GAMING motherboard: https://www.amazon.com/gp/product/B0756VTD19/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

AMD Ryzen Threadripper 2950X Processor: https://www.amazon.com/AMD-Ryzen-Threadripper-Processor-YD295XA8AFWOF/dp/B07GFN6CVF/ref=sr_1_2?keywo...

32GB's CORSAIR Vengeance RGB PRO 16GB (2x8GB) DDR4 3600MHz: https://www.amazon.com/gp/product/B07D1XJ8J9/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

ASUS ROG Strix GeForce RTX 2080: https://www.amazon.com/ASUS-Advanced-Overclocked-Graphics-ROG-STRIX-RTX-2080-A8G/dp/B07JPD4NZV/ref=s... (Trying to use this as a gaming VM with USB 3 passthrough. this is in PciE slot 1)

Radeon HD 6450: https://www.amazon.com/Sapphire-Radeon-PCI-Express-Graphics-100322L/dp/B004WYV8Z6/ref=sr_1_14?keywor... (Use this for ESXI. This is in PciE slot 3 )

3x SSD's setup in the following way:

1- 1TB SSD for VM's

1- 512GB SSD for ISO's (mount the ISO's and install from there)

1- 256GB SSD for ESXI

For some reason I can't get the onboard usb 3 ports to passthrough. I've tried to pass through all the onboard usb3 headers, two of them at first, then with one of them and every time, I get the same results.... I lose my data storage and my VM's for some reason.... yet esxi still boots?

Here the online manual for my board: https://images-eu.ssl-images-amazon.com/images/I/C1Jk738TByS.pdf of which on page 8 says I have 3 onboard USB headers.... all of which esxi is picking up. Again, does not matter which I order I try to pass through, I still lose access.

So, I did some research online and and people were saying NOT to do usb passthrough, but just to pass through the USB device. The issue here is that my mouse and keyboard are not showing up under the USB devices.

I also bought this USB card: https://www.amazon.com/gp/product/B00FPIMICA/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1 and when trying to pass this through, when powering on the VM, I get an error saying the "Device 65:0.0 is not a passthrough device"

I then went out and bought a High Point 4-Port USB 3.0 (https://www.amazon.com/High-Point-PCI-Express-RocketU-1144D/dp/B015CQ8DCS ) and it's not working either. Same error:

   Power On VM Key

haTask-1-vim.VirtualMachine.powerOn-105

Description

Power On this virtual machine

Virtual machine (machine Name)

State Failed - Module 'DevicePowerOn' power on failed.

Errors

  • Module 'DevicePowerOn' power on failed.
  • Device 65:0.1 is not a passthrough device.
  • Failed to start the virtual machine.

Anyone have any ideas?

0 Kudos
2 Replies
daphnissov
Immortal
Immortal

Everything about what you have and what you're doing is unsupported. If you're new to ESXi, a little experienced advice: Stop passing through hardware to virtual machines. If you need VMs to have access to physical hardware, don't use a hypervisor; keep your machines physical.

0 Kudos
SoloCon
Contributor
Contributor

I see 100's of posts regarding passing through video card and USB's to the VM's. While I understand it might not be supported, I was asking for some assistance on how I should try to resolve the issue instead of just giving up. I'm trying to pass through one video card and one set of USB's (for mouse and keyboard) to one VM.

0 Kudos