ilmara
Contributor
Contributor

Permission problem using vmware-vmrc.exe

Hello,

I kept receiving "Error opening the remote virtual machine http://...Permission to perform this operation was denied" when a user try to connect through vmware-vmrc.exe

- I've got this error ONLY when using vmware-vmrc.exe. If I connect through the vSphere client, everything works as expected

- The user receiving this error have VM->Interaction, and Datastore->Browse rights. I tried to change this user group to localadmin, set rights to administrator with and without propagation to no avail.

- I've tried multiple versions of vmware-vmrc.exe (2.5.0.1064 and 2.5.0.671)

Any ideas what could cause this problem ?

0 Kudos
3 Replies
Hubschrauber
Contributor
Contributor

I encountered the same problem using VMWare Server 2.0.2.

It isn't an obvious requirement but it seems that a user must have at least one role defined on the inventory root folder for the server before they'll be able to authenticate and access anything remotely using vmware-vmrc.exe. The Read-Only role seems to have been defined for this purpose. The Read-Only role appears to be a place holder since it does not show any of the specific permission checkboxes checked.

In the web-browser based VMWare console app...

  1. Select the inventory root folder, switch to the Permissions tab, and add the Read-Only permission for the user, with the Propogate permission checkbox checked.

  2. Select the specific VM guest in the inventory, switch to the Permissions tab, and verify that the same user has an appropriate role (e.g. Administrator) assigned for that item that should allow access via vmware-vmrc.exe. (Note: If you see the inherited Read-Only permission, select it, and click Edit permission, you'll get a message that says: "The
    selected permission is inherited from parent. Modifying it for this
    object will create a new permission in this object and will not change
    the original permission.
    ")

  3. Try connecting with vmware-vmrc.exe again.

I'm sure the actual permissions required for vmware-vmrc.exe remote access to a specific VMWare guest can be cut back from what the Administrator role grants, but the Read-Only at the root folder level seems to be required no matter what role/access is assigned to a specific object.

0 Kudos
gh0stw4lk
Enthusiast
Enthusiast

I had this exact problem and your fix worked a treat. Thanks. The read permissions had to be applied at the root level (ie <vcenter server name>.<domain name>) and all was good.

Thanks!

0 Kudos
jababr
Contributor
Contributor

Realy, this fix is OK.

But your host configuration, datastores, etc, stay visible (read-only) for that user.

I Tryed many forms of permitions to allow acces with vmrc, whitout access to host configs (in vSphere client) with no success

I stand trying

Tanks.

0 Kudos