VMware Cloud Community

Panic after RAM upgrade

Background info:

ESXi 6.0/5.1

Intel board DH57JG, BIOS 0663 (2011, latest)

Intel Core i3 540 CPU



This machine was running fine until I upgraded the RAM to 2x8GB DDR3-1333. On starting the machine, I see a proper POST with 16GB of RAM recognised. I see the ESXi boot menu, and after the 5-second delay, two screens of normal black/yellow boot messages. After the second such screen, however, I see an all black screen with the following message:

Panic: Can't find .text section in VMKernel Elf file

VMB: 390: Debug exception @ 0x400b17

VMB: 405: cr0 0x0001003f cr2 0x0 cr3 0x400002000 cr4 0x38

VMB: 407: error code 0x3 rip 0x400b17 cs 0x8

VMB: 409: rflags 0x6 rsp 0x49be60 ss0x0

VMB: 411: raz 0x0 rcx 0x0 rdx 0x1

VMB: 413: rbx 0x4176a8 rbp 0x49bec0 rsi 0x0

VMB: 415: rdi 0x428000002080 r8 0x8 r9 0x10

VMB: 417: r10 0x46bd7f f11 0x4 r12 0x417752

VMB: 419: r13 0x418023400000 r14 0x418023400000 r15 0xffff

VMB: 420: gs 0x10 fs 0x10

VMB: 422: FSbase:0x0 GSbase:0x0 kernelGSbase:0x0

VMB: 139: [0x49bec0] 0x400b17

VMB: 139: [0x49bf10] 0x404ea1

VMB: 139: [0x49bf40] 0x405068

VMB: 139: [0x49bfb0] 0x40566b

VMB: 139: [0x49bff0] 0x400233

VMB: 85: Halting.

I'm attaching a photo of the panic in case of a transcription error.

I also tried rolling back to 5.1 using the recovery boot option, but that resulted in a blank screen followed by a silent reset after approximately the same uptime compared to the failed attempt to boot 6.0.

I removed the new RAM and reinstalled the 8GB that the machine was running on prior, and it booted to 5.1 fine, and then updated to 6.0 Update 2. I then swapped in the new RAM again but got the same panic message as above.

I am currently running memtestx86+ on the new RAM in another machine, and after nearly an hour, no error.

I have tried searching these symptoms but haven't found anything that looked relevant. Can somebody shed any light on the nature of this problem or a possible fix?

0 Kudos
1 Reply

I understand that this is related to the memory upgrade, but can you check that the server is on the HCL and report back?



Graham | User Moderator | https://virtualg.uk
0 Kudos