ErinO
Contributor
Contributor

Packet Drop on Teaming

Hi,

I have configure Team for two NIC on Production LAN which carry two Vlan and the switch is configure as a TRUCK PORT.

When I plug out one of the cable from the switch on this teaming. The packet did not drop.

When I plug in the above cable, then there is about 7 time out.

What is wrong with the configuration on this virtual switch?

0 Kudos
12 Replies
JoJoGabor
Expert
Expert

How is the vswitch setup? I'm guessing its set to active/standby with failback set to yes. WHy not use Active/active in the vSwitch?

0 Kudos
depping
Leadership
Leadership

Spanning Tree?

And you probably mean trunk port Smiley Happy

Duncan

VMware Communities User Moderator | VCP | VCDX

-


Blogging:

Twitter: (*NEW*)

Available Soon: vSphere Quick Start Guide ()

If you find this information useful, please award points for "correct" or "helpful".

0 Kudos
ErinO
Contributor
Contributor

Hi,

I have verify that both the NIC Card are Active/Active

Attach are the screen shot.

Message was edited by: ErinO

0 Kudos
casselc
Enthusiast
Enthusiast

I would suspect spanning tree as well, is portfast/rstp enabled for this port?

0 Kudos
ErinO
Contributor
Contributor

HI,

i'm not a network guy but I will ask the network guy to look into it.

Am I right to say that spanning tree, portfast and rstp should be disabled for these production NIC PORT?

0 Kudos
athlon_crazy
Virtuoso
Virtuoso

Wouldn't spanning tree will result one of the uplink port automatically blocked by pSwitch like Cisco Switch? If that the case, another port should able to resume the connection I believe..

vcbMC-1.0.6 Beta

vcbMC-1.0.7 Lite

http://www.no-x.org
0 Kudos
JoJoGabor
Expert
Expert

Enabling portfast on your switch uplinks will improve failback times

0 Kudos
casselc
Enthusiast
Enthusiast

Am I right to say that spanning tree, portfast and rstp should be disabled for these production NIC PORT?

Portfast (Cisco) or RSTP (other vendor) should be enabled - you want to bypass the listening/learning phase of spanning tree so that the port starts forwarding traffic as soon as the NIC is reattached.

0 Kudos
ErinO
Contributor
Contributor

Hi,

The cisco switch 3750 is autonegotiate.

On the vmware virtual switc NIC, i also set from full duplex to autonegotirate. The Loading balancing address has been change from using "virtual port id" to "source mac address' and the issue persist.?

Pls help

0 Kudos
Rumple
Virtuoso
Virtuoso

If you have a cisco 3750 switch (or stack), and you have multiple physical nic's on one vswitch you should be configuring the cisco side as a trunked port group with mode on creating an etherchannel port group. Ensure portfast is enabled and set the native vlan to something that will never cross the trunk (if vlan tagging is required).

0 Kudos
ErinO
Contributor
Contributor

Hi,

If you have TRUNK configure on the Cisco switch, is Portfast still valid for such configuration?

One of my colleage have configure ethernelchannel and after that, the server cannot ping each other, thus ethernetchannel is removed?

Is the vswitch set to autonegotiate the BEST PRACTICE? Any document on this?

Thanks

0 Kudos
Rumple
Virtuoso
Virtuoso

When running GigE, you always set things to autonegotiate.

If they set etherchannel and did not configure the vlan's correctly you will have issue with pinging. Make sure you put a portgroup on your vswitch AND set the Native vlan on the etherchannel to be something that is not in use (this forces all packets to be tagged)

0 Kudos