sjkoehler
Contributor
Contributor

Out of options for vmdk recovery

Have (2) 2TB SATA disks in my ESX desktop, and one was going bad and failures prevented me from getting all of my data off the VM.

I tried transferring through vSphere the VM to the other datastore, but it failed somewhere in the middle. I tried taking a combination of everything I had pulled off and putting it on a new 4TB SATA disk that's setup as a datastore, but didn't have any luck attaching the disk to another VM. THEN, somehow I deleted a bunch of files (no clue how), so here's what I'm left with sitting on a USB drive:

VMWin2k12DC001-flat.vmdk

VMWin2k12DC001-000001-delta.vmdk

VMWin2k12DC001-000002-delta.vmdk

This file I somehow lost entirely in the mix and I last had it sitting on my 4TB SATA disk:

VMWin2k12DC001-000001.vmdk

Can anyone tell me what files I specifically need to be able to read the vmdk with a tool like UFS File Explorer? I can read the flat file, but of course that must be my initial snap and doesn't have any of the data I need to save.

Do I need a VMWin2k12DC001-000001.vmdk and a VMWin2k12DC001-000002.vmdk to get at my full disk?

I tried using UFS File Explorer to see if I could "undelete" VMWin2k12DC001-000001.vmdk, however when I scan for lost files, alls that show recoverable are awkward named *node* files. Similar if I use UFS File Explorer on the other (2) 2TB disks.

I've also tried DiskInternals VMFS Recovery 1.5, but on at least one of the disks it seems to hang on a scan.

I'm guessing I'm past the point of being able to recover, but hoping there might be a slight chance. Any help is appreciated.

0 Kudos
1 Reply
continuum
Immortal
Immortal

do you see the missing delta files if you inspect the datastore with vmfs-fuse from a Linux LiveCD ?


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos