berberich
Contributor
Contributor

One of Two vSphere ESX4i hosts cannot find new iSCSI LUN

Current Setup:
  • Dell EqualLogic iSCSI SAN
  • 2 ESXi hosts (esx01, esx02) running ESXi 4.0.0
  • vSphere version 4.0.0
  • 6 LUNs configured
  • 2 Datastores shared between esx01 and esx02 (Datastore01, Datastore02)

What I'm trying to do:

Add a 3rd shared Datastore accessible by both esx01 and esx02 (called Datastore03)
What I did:
  1. Setup new LUN on the SAN
  2. 2. On esx01, rescanned/refreshed the Storage Adapters. This caused a new entry to appear under the Details > View (Devices) section of the Storage Adapters screen.
  3. Also on esx01, I then went to Storage > Add Storage > Disk/LUN, selected the identified LUN and added it as Datastore03.
  4. Verified that Datastore03 shows under the Datastores list on the Storage screen.

esx01.png

What's not working:
I did the same Storage Adapter rescan/refresh on esx02, however this did not result in the new LUN appearing under the Details > View (Devices) section. This means that I'm not able to get the esx02 server to recogize Datastore03 (it does not appear under the Datastores list on the Storage screen).
esx02.png
However - When I click on Properties on the Details section of the Storage Adapters tab and look at the Static Discovery tab, I do see it as an iSCSI target as target name iqn.2001-05.com.equallogic:0-8a0906-d932edf02-e755a12774d4dc15-datastore03
What I've tried:

  • Multiple rescans/refreshes of the iSCSI Software Adapter
  • Multiple refreshes of the Datastores list on the Storage screen
  • Reboot of esx02 host
  • Reboot of the vSphere vCenter server


It has been awhile since I last added Datastore02, but it worked without issue at that time, so I'm unsure of what else to check at this point.

Anyone have suggestions?

0 Kudos
3 Replies
AndreTheGiant
Immortal
Immortal

Have you set the correct access rules on Eql side?

Also, have to set the volume to be shared (still on Eql side)?

Andre

Andre | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
berberich
Contributor
Contributor

I went in and checked the EqualLogic settings after your suggestion, and sure enough, there was a checkbox to "Allow simultaneous connections from initiators with different IQN names" that was unchecked. I didn't remember checking this in the past, but when I looked at the other datastores, it was enabled.

After enabling it on the new DS, it works as expected.

Thanks you for your help.

0 Kudos
Satcom1973
Contributor
Contributor

Thank you berberich!  I forgot about the check box for "Allow simultaneous connections...." and that did the trick!  

0 Kudos