pbraren
Hot Shot
Hot Shot

Now that you installed ESXi 6.0 with another NIC, here's how to easily enable both Realtek NICs and SATA AHCI Controllers

I'm assuming you found this post because your Realtek NICs (8168/8169, and some 8111E) that you may have had working in prior ESXi releases disappeared, and/or datastores attached to some ASMedia ASM1062 SATA ports disappeared.

So, if the following things are true:

  • your ESXi 6.0 host was built with another recognized NIC
  • your ESXi 6.0 host has internet access

then the following simple fix should work for you, thanks to Andreas Peetz!  The use of older VIBs on ESXi 6.0 is not supported, and your results may vary, especially the Realtek drivers, results are hit or miss.

The Fix:

1)  enable SSH (under Security Profile) on the new ESXi 6.0 host, and put it in maintenance mode if it's not already

2)  used PuTTY to connect

3)  typed in the exact commands seen below, then reboot

how to add Realtek and SATA to an already running ESXi 6.0 host.png

esxcli software acceptance set --level=CommunitySupported

esxcli network firewall ruleset set -e true -r httpClient

esxcli software vib install -n net51-drivers -d http://vibsdepot.v-front.de
esxcli software vib install -d http://vibsdepot.v-front.de -n sata-xahci

reboot your ESXi host, and your NICs and your datastores should show up again.

Pretty darn awesome!

Video of the process is included in my more detailed article:

For ESXi 6.0, those ESXi 5.1 VIBs for ASMedia SATA ports and Realtek NICs still seem to be working (but unsupported)

http://TinkerTry.com/for-esxi-6-0-those-esxi-5-1-vibs-for-asmedia-sata-ports-and-realtek-nics-still-...

See also

Re: Realtek 8168 chipset NICs and ESXi Beta2

https://communities.vmware.com/post!reply.jspa?message=2410005

How to make your unsupported SATA AHCI Controller work with ESXi 5.5

http://www.v-front.de/2013/11/how-to-make-your-unsupported-sata-ahci.html

by Andreas Peetz

[Release] ESXi-Customizer-PS 2.2 - The ESXi image customization script

http://www.v-front.de/2014/02/release-esxi-customizer-ps-22-esxi.html

by Andreas Peetz

TinkerTry.com
Tags (3)
0 Kudos
1 Reply
esullivan81
Contributor
Contributor

Hello!  I have used your post to solve my problem, thank you!  However, when I boot the server back up, the network only lasts 1-2 minutes.  Any thoughts?

0 Kudos