VMware Cloud Community
yducerf
Contributor
Contributor

No datastore after Esxi 4.0 repair

hi all,

After an esxi 4.0 reparation , after reboot, no datastores appears..

When we try http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=100228...

Sytem say that the primary partition 1 is already assigned..

Someone could tell us how to know which partition to reallign and to convert..

Regards

Reply
0 Kudos
4 Replies
a_p_
Leadership
Leadership

Welcome to the Community,

can you please explain in detail which steps you did. i.e. running the repair as well as editing the partition tables.

How does the system currently look like (what's the output of fdisk -lu)?

Has this system initially been installed with ESXi 4.0 or has it been upgraded from version 3.5?

André

PS: Discussion moved from VI: VMware ESX™ 3.5 to VMware ESXi™ 4

Reply
0 Kudos
yducerf
Contributor
Contributor

in fact, esxconsole.vmdk was missing after reboot..

so we try to reinstall esxi4.0 in reparation mode to repair..

But after reinstallation, no datastore...

We call the vmware support but for the moment they just try to find the lvm magic number to reallign partitions..

I want to try with an ultimate cd to repair the partition with testdisk ...

what do you think of that ?

Reply
0 Kudos
continuum
Immortal
Immortal

> I want to try with an ultimate cd to repair the partition with testdisk ...

> what do you think of that ?

Not a good idea - I tried that a few times but it usually does not help.

If possible repair ESXi partitions with ESXi itself.

And I made very bad experiences with the ESXi repair mode - never ever use that unless you have full backups.

Create a ESXi USB-boot stick somewhere else and use that to fix the problem


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

Reply
0 Kudos
a_p_
Leadership
Leadership

in fact, esxconsole.vmdk was missing after reboot

The "esxconsole.vmdk" is used for the classic ESX only, not for ESXi. Did you try to repair ESX 4.0 with an ESXi 4.0 CD?

André

Reply
0 Kudos