salduba
Contributor
Contributor

Nic Teaming Port ID - Different VMs use same vmnic ¿why?

Hello everybody,

I have a server with 9 physical nics and esxi 5.5 in it. Only 5 virtual machines are running.

I've configured NIC Teaming with Virtual Port ID balancing. All help documents show each VM will use one different nic until there is no free NIC.

But in my case, 2 VMs use same nic and other 2 VMs use another nic.

Better with images:

Captura de pantalla 2015-03-24 a la(s) 22.01.39.png

Captura de pantalla 2015-03-24 a la(s) 22.02.33.png

Captura de pantalla 2015-03-24 a la(s) 22.03.16.png

Captura de pantalla 2015-03-25 a la(s) 11.18.16.png

As you can see in the last image, the VMs JuanWebMoodle and AlexMoodle use same vmnic6 although they have different port ID. The same occurs with LauraMoodle and ManoloMoodle and vmnic7.

As you can see the order of the active adapters configured doesn't work, VMs should use vmnic1, vmnic2, etc...

I hope anyone can help me. Thank you very much in advance.

Best regards.

0 Kudos
16 Replies
vickey0rana
Enthusiast
Enthusiast

Can you remove the network adapter (vmnic3, that was down) from the vswitch 0 and then check again on esxtop?

---------------------------------------------------------------- If you found this or any other answer helpful, please consider to award points. (use Correct or Helpful buttons) BR, Ravinder S Rana
0 Kudos
salduba
Contributor
Contributor

OK. It's done. Bad news, it remains the same.

Captura de pantalla 2015-03-25 a la(s) 12.26.05.png

Captura de pantalla 2015-03-25 a la(s) 12.26.30.png

Anyway, thank you very much.

0 Kudos

as I know the switch port is allocated on the startup of a VM.

So you probably have to shut down and start the vms again to "loadblanace" it...

------------------------------------------------------------------------------- If you found this or any other answer helpful, please consider to award points. (use Correct or Helpful buttons) Regards from Switzerland, B. Fernandez http://vpxa.info/
0 Kudos
salduba
Contributor
Contributor

ok, I have turned VMs off, and start again. Bad news. VMs use a new vmnic, but they repeat it again.

Captura de pantalla 2015-03-25 a la(s) 12.53.59.png

Thank you for trying it.

0 Kudos
vickey0rana
Enthusiast
Enthusiast

I want you to try another thing that is just keep only 8 vmnics in team.. remove vmnic8 from teaming and thn try the same..

---------------------------------------------------------------- If you found this or any other answer helpful, please consider to award points. (use Correct or Helpful buttons) BR, Ravinder S Rana
0 Kudos

btw. in the portgroup  options you can also define which vmnics he should use...not only in the vswitch options.

------------------------------------------------------------------------------- If you found this or any other answer helpful, please consider to award points. (use Correct or Helpful buttons) Regards from Switzerland, B. Fernandez http://vpxa.info/
0 Kudos
salduba
Contributor
Contributor

Thank you everybody for keep trying it.

But..... bad news. I've removed the last vmnic, that is vmnic9. Now, I have 1 nic for management and 7 nics for VMs. Total 8 nics.

At least the vmnics order seems to work.

Captura de pantalla 2015-03-25 a la(s) 13.19.33.png

Captura de pantalla 2015-03-25 a la(s) 13.19.09.png

Thank you again.

0 Kudos
salduba
Contributor
Contributor

Yes bruno, I know it, but I don't want to force vmnics for each port group. It should works well with one configuration for the whole vswitch.

Thank you.

0 Kudos

on this you are right Smiley Happy

------------------------------------------------------------------------------- If you found this or any other answer helpful, please consider to award points. (use Correct or Helpful buttons) Regards from Switzerland, B. Fernandez http://vpxa.info/
0 Kudos
vickey0rana
Enthusiast
Enthusiast

Not sure but was reading the networking document of VMware and found below:

• Route based on the originating virtual switch port ID — Choose an uplink based on the virtual port where the traffic entered the virtual switch. This is the default configuration and the one most commonly deployed. When you use this setting, traffic from a given virtual Ethernet adapter is consistently sent to the same physical adapter unless there is a failover to another adapter in the NIC team. Replies are received on the same physical adapter as the physical switch learns the port association. This setting provides an even distribution of traffic if the number of virtual Ethernet adapters is greater than the number of physical adapters.

Can you ensure you have virtual Ethernet greater than physical adapters?

---------------------------------------------------------------- If you found this or any other answer helpful, please consider to award points. (use Correct or Helpful buttons) BR, Ravinder S Rana
0 Kudos
salduba
Contributor
Contributor

Thank you bruno and vickey,

VickeyOrana, I don't understand very well that paragraph, for my english it is a little bit complicated, but I'm going to explain you my NICs.

I have a DELL 2950 server, with ESXi 5.5. The server has 10 RJ45 ports 1000Mbps plus 1 DRAC RJ45 port (remote server management). Total 11 ethernet ports.

One of those 10 ports or nics (they are synonymous, right?) seems to be broken. Therefore only 9 nics work for ESXi.

I installed ESXi 5.5 and it recognized every nic in the server, and vmnics (0-9) appeared.

I configurated Nic teaming creating portgroups (same number than vmnics) to get load balancing. And now, one hour ago, I removed vmnic3 because it was the broken port.

It is supposed that putting each virtual machine in each portgroup I should get load balancing. That is, each virtual machine will use one nic of 1000Mbps. All of this without I configure manually each portgroup with each vmnic.

I don't know if I've get explain it well. I hope it.

Best regards. Thank you very much.

0 Kudos

as I said VMWare recomends also to configure it on the portgroup:

VMware KB: Virtual Port ID based Load Balancing: Multiple vmnics teamed together however only 1 vmni...

------------------------------------------------------------------------------- If you found this or any other answer helpful, please consider to award points. (use Correct or Helpful buttons) Regards from Switzerland, B. Fernandez http://vpxa.info/
0 Kudos
admin
Immortal
Immortal

There's something quite odd there - the esxtop output shows vmk0 on vmnic0 (on vSwitch0), but the screenshot shows that vmnic0 is unused in vSwitch0.

0 Kudos
salduba
Contributor
Contributor

jwalsh,

I think it's the correct behavior. When I configure vmnic0 only for management network it shows as unused.

Bruno,

I will read the article later. Thank you.

Thanks to everybody.

0 Kudos
salduba
Contributor
Contributor

Bruno,

I've already read the article. It just indicate select "Override vSwitch Failover order" in every portgroup. I've done that, but everything stays the same.


I've just reboot the server, but equal. Now it repeats vmnic5 and 6, and the order does not work, again.


Captura de pantalla 2015-03-25 a la(s) 21.15.50.png


If we don't find anything more, only I can force one nic per virtual machine, manually, but esxi configuration would lose "the automation".


Thank you very much.

0 Kudos
vickey0rana
Enthusiast
Enthusiast

Thank you for explaining the scenario:

As per my understanding on the article given in my last post, it says it will distribute the load in case Virtual Ethernet (vnics) is greater than Physical Ethernet (vmnics).

So would recommend you to keep any 4-5 physical NICs in vSwitch and remove remaining NICs, then bounce the VMs Network settings from vCenter and check esxtop again.

---------------------------------------------------------------- If you found this or any other answer helpful, please consider to award points. (use Correct or Helpful buttons) BR, Ravinder S Rana
0 Kudos