Highlighted
Contributor
Contributor

Need a VIB package for 10Gig NICs...

I just bought SuperMicro X10SDV-TLN4F motherboard and I can't get the two 10GbaseT NICs to show-up in ESXi 5.5.  I believe I need a VIB package for them but I can't find one posted anywhere online.


Has anyone gotten this board working with the two 10Gig NICS

0 Kudos
18 Replies
Highlighted
Expert
Expert

Do you have any further details on the chipset used for the 10GB nics? The 2 1GB nics are Intel i350 but nothing said about the 2 10GB on Supermicro's page...

0 Kudos
Highlighted
Expert
Expert

Sorry, just missed that this is a relatively new Broadwell Xeon-D chipset. Guess the only option is to use VMWare 6 with that which might support the 2 SoC 10GB nics.

0 Kudos
Highlighted
Contributor
Contributor

Already tried ESXi 6, no difference.

0 Kudos
Highlighted
Expert
Expert

Have you checked Intel's support pages, maybe they provide a driver for VMWare?

0 Kudos
Highlighted
Contributor
Contributor

I got linux drivers from SuperMicro's tech support but I don't know how to compile it into a VIB package to get them installed in VMware.  I've looked at a few guides but that kind of stuff is way over my head.  I'm not a programmer at all.

0 Kudos
Highlighted
Expert
Expert

I guess it will be natively supported with a future build of VMWare 6, you just could try to find a driver from another mainboard vendor.

0 Kudos
Highlighted
Contributor
Contributor

But what good is a driver going to be if it's not a VIB package?  Motherboard vendors don't provide VIB files for use with VMware.  I think at this point I'm just going to have to wait until more people adopt these boards as they are quite new.

0 Kudos
Highlighted
Expert
Expert

Maybe one of the larger server vendors (IBM/Lenovo, HP, DELL ...) jumps in here.

0 Kudos
Highlighted
Enthusiast
Enthusiast

I know that HP Gen8 servers have Intel I350 Powerville Network controller.

So maybe one can try latest HP ISO image. But cannot find any reference to I350-AM2.

The VMware HCL has some references to I350, but not I350-AM2 specifically.

http://www.vmware.com/resources/compatibility/vcl/result.php?search=i350&searchCategory=all

But the drivers listed there are already inbox, so if they do not find the NICs, the async driver will probably not do, too.

0 Kudos
Highlighted
Expert
Expert

The Intel I350 1GB drivers are not the problem. Those should be working. He's looking for drivers for the on-SoC 10GB NICs. Those are Broadwell chipset specific.

0 Kudos
Highlighted
Contributor
Contributor

Correct.  This is how the NICs show up in Windows.

All 4 NICs_zpsgtxx1fxl.jpg

0 Kudos
Highlighted
Enthusiast
Enthusiast

I said this in another thread along the same lines, asking about these drivers...

There has been support for Linux for 2 driver releases now. ixgbe 4.0.3 (April 15 release) and now ixgbe 4.1.1 (June 17) - see here. For whatever reason, neither version has made it into a VIB driver package. The most recent VMWare driver is 3.23.21, which is from February.

Not keeping up on the driver releases that support the Intel 10GbE adapter in the Xeon D-1540 SoC kills the product line for visualization, unless you're going with Hyper-V or some variant of Linux (KVM / Xen / etc.)

The NIC driver is the only thing stopping me from deploying the D-1540 in my own cluster. Given that we now have native bandwidth hungry features like VSAN and 4 vCPU Fault Tolerance available to us, 10GbE is pretty much a staple for VMWare now. Have it, or pay the price - only we can't get it because the drivers haven't been updated in 4 months. Where's 4.0.3, at the very least?

0 Kudos
Highlighted
Contributor
Contributor

Yea it's really unfortunate that it's taking this long to get VMware to support these NICs.  This is a hugely popular platform for small and large businesses going forward so I can't imagine them being able to afford neglecting it for long.

0 Kudos
Highlighted
Contributor
Contributor

So frustratingly I'm in the same boat...I put my name on a long term pre-order based on SuperMicro's stated ESXi6.0 support for this board. Whilst there was a statement on the SATA controller requirements for support the 10GbE SoC NICs weren't mentioned.

I've corresponded with SuperMicro support in the Netherlands who advise no driver exists and that although they have no doubt someone will create one they can't give me a schedule.  They've accepted that the OS compatibility matrix is wrong (and is based on the quad 1GbE model) and assure me they will update the website to clarify the issue.

Now l guess I have to talk to the reseller about my return/discount options.... 😞 

0 Kudos
Highlighted
Enthusiast
Enthusiast

That is unfortunate. Everything reportedly works fine, except the 10Gbps NICs. If you have the board without the 10Gbps NICs, you're good - though nothing with a Broadwell-DE processor series in it is currently blessed by VMWare yet on their compatibility list, I'm fairly confident it will be. This thing is built for visualization, so it's just a matter of time, you'd think.

In the meantime, someone will most likely get the *nix driver into a vib, if unofficially, since there's mounting pressure to do so as people scramble to get these servers from the various vendors (currently Supermicro and ASRock (of all places) has one shipping, but more are coming from other vendors). The question is when, as you and Supermicro have said.

If people keep talking about the need for the 10Gbps NIC driver, maybe that'll motivate some movement on the issue from one source or another. Smiley Happy

0 Kudos
Highlighted
Contributor
Contributor

Still no update on this eh?

0 Kudos
Highlighted
Enthusiast
Enthusiast

Nothing I'm aware of. There was talk in another thread on the same subject that ESXi 6.0b was released, but there was no update to the VIB for the ixgbe driver - it's still the 3.x version from several months ago. No 4.x version yet.

0 Kudos
Highlighted
Hot Shot
Hot Shot

Good news today, found over at this closely related thread (also on VMware communities):

Re: When will Intel(R) Ethernet Connection X552/X557-AT 10GBASE-T be supported in vSphere 6?

I don't believe Supermicro ever claimed 5.5 compatibility, and I don't really know if 5.5 will ever be supported for this chipset, but it seems likely we'll know more soon. Meanwhile, the outlook for 6.x looking promising!

TinkerTry.com
0 Kudos