NVIDIA Tesla K80 - Pass Through


I have a problem using a GPU hardware (NVIDIA Tesla K80) in an HP blade.

Since vGPU drivers are not available for this NVIDIA we tried the pass through configuration reported in this blog: however the full config is not working in our installation, when applied to a Windows 10 Pro, the VM no longer boots. When using just pciPassthru.use64bitMMIO="TRUE" config line, I can detect the new hardware in Win10 VM, but NVIDIA instalation of drivers "356.54-tesla-desktop-win10-64bit-international-whql.exe" never completes.

I also tried to install NVIDIA drivers in an ubuntu-16.04.1-server-amd64, but the VM was destroyed in this process (was unbootable after the installation).

I had also previous problems that can be related:

Our blade also has an "HP P440ar RAID controller" problem, and we opted to install ESXi software VMware-ESXi-6.0.0-2494585-HP-600.

since we don't have much experience in building custom images.

Tried also to file a VMWare support ticket, but the SnS is assigned to the institution that I work for. In My VMware account can't file the ticket because I don't have any product registrations.

I have all the SnS information (email info of Service Activation), but don't know how to use this info for my account.

Any help?

Tags (1)
1 Reply

I have the same problem. The solved method is .

1.  mainboad bios option: SR-IOV =enable, ASPM=enable/auto

2. vm's vmx add

      1 pciPassthru.use64bitMMIO=”TRUE” 

      ?2 pciPassthru.64bitMMIOSizeGB = “64