actyler1001
Enthusiast
Enthusiast

NTP broken after ESXi 7u3 upgrade

NTP time sync appears to have broken after the 7U3 upgrade.  Anyone else run into this and have suggestions on how I might fix?  I've deleted and re-created the service, checked FW policy, tried different servers...  Nothing helps.

Original Build: VMware ESXi, 7.0.2, 17867351

actyler1001_1-1635089620144.png

 

New Build: VMware ESXi, 7.0.3, 18644231

actyler1001_0-1635089532365.png

 

Labels (2)
101 Replies
TPGOPI007
Contributor
Contributor

The NTP issue still persist.


vCenter: 7.0.3 Build: 19717403

VMware ESXi, 7.0.3, 19898904

0 Kudos
actyler555
Enthusiast
Enthusiast

Me too.  But I am running...

VMware ESXi, 7.0.3, 19482537

GUI reports "Time service is currently not synchronized".

0 Kudos
maxr91
Contributor
Contributor

Why I am not surprised? 

I assume it will be solved already in ESXi 7.5. 

0 Kudos
LabMasterBeta
Enthusiast
Enthusiast

You didn't hear the news?  Broadcom bought VMware.... Maybe things will now improve.

0 Kudos
loungehostmaste
Enthusiast
Enthusiast

how old are you? 15? or why do you imagine things will become better after anotherbpure hardware crap company bought VMware?

0 Kudos
jtawney73
Contributor
Contributor

Still an issue as of 6/22/22!

0 Kudos
KuotaiDavidSu
Enthusiast
Enthusiast

Yep, same here 06/23/22

0 Kudos
PhillipA
Contributor
Contributor

@sramanuja I have SR #22341623706 raised. Happy to share log bundle 

0 Kudos
maxr91
Contributor
Contributor

Let the force be with you 🙂 It can take a while now.

of course, waiting for a solution and updates from you

0 Kudos
aritri
Contributor
Contributor

This should be the solution to the NTP issue: https://kb.vmware.com/s/article/87488

Additional informations: https://kb.vmware.com/s/article/87176

 

0 Kudos
loungehostmaste
Enthusiast
Enthusiast

for the sake of god how should https://kb.vmware.com/s/article/87488 be related to this issue?

0 Kudos
aritri
Contributor
Contributor

ESX 7.0.3 allows a time difference of 1,5 seconds to the ntp server. In this KB article the value is changed to 30 seconds and should solve the ntp synchronisation issue.

0 Kudos
loungehostmaste
Enthusiast
Enthusiast

than answer that instead of a article about unrelated config stuff given that literally nobody did change the ntp config outside the vCenter UI and it#s still something VMware has to fix - when my hosts and ntp servers differ for more than 10 seconds i commit suicide anyways so that can't be underlying issue

0 Kudos
aritri
Contributor
Contributor

Calm down and keep it professional.

It's not unrelated and you would know that if you read both articles. You can use the solution as a workaround or not, that's up to you.

Have a nice day.

0 Kudos
loungehostmaste
Enthusiast
Enthusiast

nobody needs another workaround - the first one dsiable the alert just works fine - we need a solution from the clowns at VMware and i get back to be professional when they manage their homework and stop acting like microsoft - the whole vSpehere 7.x stuff is a bad joke and every single time i get a mail notrify of a reply in this thread which don't contain the words "the latest update one and for all will fix this issue" i get angry - peruiod

0 Kudos
gopinathan
Contributor
Contributor

None of those KB posted here address the issue. And the workaround is not acceptable/practical. We always set NTP using esxcli command.

0 Kudos
gopinathan
Contributor
Contributor

Not related to the NTP issue. I went to edit my profile and below are the options I have :). Really VMware?

 

ICQ number
 
AIM screen name
 
MSN Messenger screen name
 
Yahoo ID
 
Skype name
0 Kudos
LabMasterBeta
Enthusiast
Enthusiast

@aritri   Your posts, "ESX 7.0.3 allows a time difference of 1,5 seconds to the ntp server. In this KB article the value is changed to 30 seconds and should solve the ntp synchronisation issue."

No, the links you posted for modifying NTP.conf is unrelated to the issue.

Quick recap of this thread:

1.) Clean-Install of ESXi 7.0u3d, without changing anything at all, the "out of box" experience NTP is broken - In multiple ways that have been detailed in this thread.

2.) An Employee of VMware posted here, reproduced the issues and confirmed that NTP is broken, and admitted it's such a low-priority to VMware engineering they need more customer SR's to be submitted as complaints to get engineering at VMware to prioritize fixing NTP in vSphere 7.0.

So, if you want to help, please know that we all know how to use google, and if you want to really impress everyone - Then find a way to escalate this NTP issue to VMware engineering to provide a patch.

THAT would be incredibly helpful and much appreciated by everyone.

LabMasterBeta
Enthusiast
Enthusiast

Has anyone brave enough tried the new ESXi 7.0.3-Update3e yet?

NOTE: It's best-practices to always update vCenter before ESXi especially with security-focused updates like this one (e.g. VCSA Update3e).

This ESXi build was released 6/14/2022, but not posted as ISO image as-of 6/29/2022:  VMware-ESXi-7.0U3e-19898904-depot.zip

https://docs.vmware.com/en/VMware-vSphere/7.0/rn/vsphere-esxi-70u3e-release-notes.html#patch-downloa...

I see nothing about NTP in release notes, looks to be almost-all Security patches; but, I was hoping MAYBE they slipped in a NTP fix with all those security patches.. One can only hope!

I will not have time to test this latest build in our lab for 1-2 weeks but I'm curious.

 

0 Kudos
TPGOPI007
Contributor
Contributor

Still broken in 70u3e.

BTW, you can create an ISO from the ZIP bindle, using image builder cmdlets. 

Tags (1)
0 Kudos