insearchof
Expert
Expert

NFS Data Store Will Not Mount on one Esxi Host

Jump to solution

VMware ESWXI 6.5

I have 8 ESXI 6.5 hosts with many VM's

I have NFS storage shared across all ESXI Hosts.

On one ESXI host it does not appear in the data store list.

When I go to the Dat store tab on my Datacenter I right click on the NFS storage and select Mount Datastore to Additional Hosts

The Esxi host show in the list I select it

I get this error

The specified key, name, or identifier "Datastore name' already exists.

Any ideas?

I was thinking maybe a restart of the host but was hoping  command to try.

Thank you

Tom

0 Kudos
1 Solution

Accepted Solutions
ThompsG
Virtuoso
Virtuoso

Hi there,

Yes there is a command to remove the NFS mount. Just run the following from the shell interface:

esxcli storage nfs remove -v <VolumeName>

Replace <VolumeName> with the one you want to dismount. Before doing this make sure there are no VMs running on this NFS store on the ESXi server you are running it from. Once completed then try mounting again from the vCenter console.

Oh and yes it could just be the browser session. You might like to either try another browser or empty the cache before attempting the above.

Let us know how it goes Smiley Happy

View solution in original post

0 Kudos
7 Replies
ThompsG
Virtuoso
Virtuoso

Hi Tom,

The problem is likely that the NFS mount is already exported to this host, probably with a different NFS server name and most likely with a different configuration, i.e. one is mounted using the NFS IP address and the other using the NFS server name.

To confirm do one of the following:

1. From the Host object, select the DataStores view under Related Objects. Then right click the column headings, select Show/Hide Columns and ensure Devices is enabled. Then check and see if the NFS share is mounted using a different configuration than the others.

2. Using SSH, connect to the host and run "esxcli storage nfs list" - this will again output the NFS mounts and see which has a different configuration from the other hosts.

After you have identified the rogue connection and ensuring no VMs are running from it on this host, disconnect and then connect using the "Mount Datastore to Additional Hosts..." option.

Let us know if this helps.

0 Kudos
insearchof
Expert
Expert

ThompsG

Nothing showed up in the related objects view

I then SSH'd and ran this

[root@TGCSESXI-3:~] esxcli storage nfs list

Volume Name  Host       Share             Accessible  Mounted  Read-Only   isPE                                                                                                                Hardware Acceleration

-----------  ---------  ----------------  ----------  -------  ---------  -----                                                                                                                ---------------------

NFS02        10.2.8.51  /NFS02/esxiadmin        true     true      false  false                                                                                                                Not Supported

NFS01        10.2.8.13  /volume1/NFS01          true     true      false  false                                                                                                                Not Supported

[root@TGCSESXI-3:~]

On a host that has the NFS storage showing looks the same

[root@TGCSESXI-4:~] esxcli storage nfs list

Volume Name  Host       Share             Accessible  Mounted  Read-Only   isPE  Hardware Acceleration

-----------  ---------  ----------------  ----------  -------  ---------  -----  ---------------------

NFS02        10.2.8.51  /NFS02/esxiadmin        true     true      false  false  Not Supported

NFS01        10.2.8.13  /volume1/NFS01          true     true      false  false  Not Supported

[root@TGCSESXI-4:~]

could it be just the browser session ?  Or a restart of the host?

Is there a dismount command via SSH ?

Thanks

0 Kudos
ThompsG
Virtuoso
Virtuoso

Hi there,

Yes there is a command to remove the NFS mount. Just run the following from the shell interface:

esxcli storage nfs remove -v <VolumeName>

Replace <VolumeName> with the one you want to dismount. Before doing this make sure there are no VMs running on this NFS store on the ESXi server you are running it from. Once completed then try mounting again from the vCenter console.

Oh and yes it could just be the browser session. You might like to either try another browser or empty the cache before attempting the above.

Let us know how it goes Smiley Happy

View solution in original post

0 Kudos
insearchof
Expert
Expert

It all worked

Thank you

Tom

0 Kudos
ThompsG
Virtuoso
Virtuoso

Awesome - great work and have a fantastic day!

0 Kudos
AlexChato9
Contributor
Contributor

Unfortunately, nothing shows up for me when I enter esxcli storage nfs list... However, ESXi keeps telling me that the datastore already exists... What else can I do?

0 Kudos
scott28tt
VMware Employee
VMware Employee

Moderator: Thread moved to the ESXi area.

0 Kudos