VMware Cloud Community

Mount Host USB Device in VMRC or Web Client

Hi folks,

Im tearing my hair out over this one.

I have spent the last day poring over google and trying to work out how to mount a USB drive from my host device to my VM on ESXi 6.5.

I have added a USB Host controller without issue. However, there is no further option available to add a Host USB Device (as i have seen on some tutorials) or to Select USB Device from the menu in VMRC - in VMRC I only have the option for DVD, Floppy(!), and Network adapter, but no USB (not even a greyed out option).

I even tried to enable Passthrough so that at least I could connect the drive to the server host and perhaps access the USB device that way, but that didnt work either.

Is there anybody that can help here with perhaps a checklist? Am I missing some settings buried deep within the advanced settings panel?

For such a relatively simple thing (it was so simple in VMWare workstation) - I just cant fathom why its not working.

Any advice or help is greatly appreciated!



0 Kudos
2 Replies
VMware Employee
VMware Employee

Hello TP,

"I even tried to enable Passthrough"

There is no other way of getting a USB device direct to a VM unless you are talking about storage medium in which case can just put an FS on it.


- Add USB controller to host:


- If the host is not picking up the USB then try disabling vmkusb driver (so that legacy drivers are loaded instead after reboot),


as this appears to be causing issues for some folks (+ other info including possibly necessary vmx configurations in this thread):


- Add USB device to VM via Web Client:



- Ensure that the VM Guest OS has the drivers necessary to use such a device.


0 Kudos

Hi Bob,

Finally I have found the root cause issue. The VMWare USB Arbitration service was not running on the Client running VMRC.

Once I rebooted the machine the service was running again and I had the option to connect a USB device (once the USB host controllers were installed on the VMs).

Many thanks anyway for you useful pointers.

0 Kudos