VMware Cloud Community

Machine won't boot after expanding hard drive size with vmkfstools

Hopefully someone can help me out here and point me in the right direction - I am sort of new to VMWare here.

I have a Windows XP guest that the hard drive had filled so I wanted to expand the disk size a little for some breathing room.

I used the post here - http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=100726... to accomplish this goal.  I have done this a few other times as well - and it has always worked well.

This particular instance, I expanded the drive from to 60 GB using the interface.  Connected the drive to a windows 2008 r2 server, extended the partition, removed the added drive. Tried to boot the Windows XP machine and all I get now is a blinking cursor in top left of the console window.

Of course - I don't have a back up.  I did verify that I can still see all of the data on the drive - for some reason, it just wont boot?!?

Any suggestions out there?

Thanks in advance.


0 Kudos
1 Reply

Hi sb,

It seems for me like partition is not set up as boot partition. Probably w2k8r2 clear a bootable flag on win XP partition.

Try to mount win XP disk to Linux machine and use

# fdisk -l

fdisk /dev/sdb <-- you attached win disk

p <-- to print partition layout

a <-- to toggle bootable flag

Partition number (1-4):  <-- here is number of your win xp system partition

w <-- write changes



0 Kudos