Contributor
Contributor

Lowest supported VMFS Version on ESXi 5.x?

Hi

I've got a customer whos vSphere environment I want to upgrade to version 5.1. The hosts are currently running ESXi 4.1 and have two datastores attached. These are both on VMFS Version 3.31.

Now I have had a similar case where an upgraded 5.0 host wouldn't recognize a datastore with VMFS Version 3.21. Apparently datastores created on ESX 3.0.0 hosts are not supported on ESXi 5.x hosts.

Now my question: What is the lowest VMFS Version that an ESXi 5.x (5.1.0 UP1 in my case) will recognize / support? Im googled a while and haven't found any info directly from VMware. All I found was a blog article where the author mentioned that 3.31 onward is compatible. (Cosonok's IT Blog: Notes on Migrating from Compaq MSA1000 to VMware vSphere 5). Can anybody acknowledge this statement? Is 3.31 the lowest supported VMFS Version a ESXi 5.x host can work with?

Thanks alot Smiley Happy

David

Tags (4)
0 Kudos
4 Replies
Hot Shot
Hot Shot

Worth reading : VMFS-5 VMFS-3, What’s the Deal? » boche.net – VMware vEvangelist

  • You will use VMFS3 if you have a vSphere environment which is mix of vSphere 4.x (also 3.x) & 5.x hosts. Presently VMFS5 datastores cannot be accessible to hosts running an ESXi version less than vSphere 5.0

http://www.myitblog.in/
0 Kudos
Contributor
Contributor

JD schrieb:

Worth reading : VMFS-5 VMFS-3, What’s the Deal? » boche.net – VMware vEvangelist

  • You will use VMFS3 if you have a vSphere environment which is mix of vSphere 4.x (also 3.x) & 5.x hosts. Presently VMFS5 datastores cannot be accessible to hosts running an ESXi version less than vSphere 5.0

I read the article before posting, but it doesn't answer my question. Of course I know that VMFS3 is used while having a mix of host systems and that VMFS5 isn't accessable by lower versions. My question is do ESXi 5.x hosts support VMFS 3.31 or even VMFS 3.21?

0 Kudos
Immortal
Immortal

Both vmfs 3.31 and vmfs 3.21 can be used with esxi 5.x hosts

0 Kudos
Contributor
Contributor

As for support, the broad understanding is this:

VMware vSphere 5.1

Fine reading says "Host Access" ...that means storage is accessible.. now if your client is on 4.1 & have thin provisioning enabled, I would assume that they are on VMFS 3.33 ( Not a thumb rule though)

Now reading this, VMware vSphere 5.1

Fine reading says "After you upgrade your VMFS2 datastore to VMFS3, the datastore becomes available on the ESXi 5.x host. You can now use the ESXi 5.x host to complete the process of upgrading to VMFS5."

So what I would understand is that starting from 3.21, 3.31, 3.33 & 3.46 (3.x) should be accessible on ESXi 5.x ( however the usability differs on VMFS versions). I hope that helps. Would love to hear from you about your findings.

0 Kudos