MidwestFinishin
Contributor
Contributor

Local Datastore expansion on ESXi 6.5

We are having the same problem on a Dell R630.  The missing step is to do what?  Another BIOS Step?

Moderator Note - a.p.: Branched the question from Local Datastore on ESXi 6.5 question​ to a new discussion.

0 Kudos
4 Replies
a_p_
Leadership
Leadership

Welcome to the Community,

please provide some details about the current state.

  • Did you already resize the RAID set?
  • Did you already resize the logical volume(s) (IIRC, Dell calls them VDs)?

What did you do so far? Maybe some screenshots will help.


André

0 Kudos
MidwestFinishin
Contributor
Contributor

We installed the Dell customized ESXi 6.5.  Yesterday we applied 6.5 U2, and inserted two more drives which we added to the RAID 5 array.  This doubled the available space, as can be seen in the screen shot.  Now in the esxi web client we are trying to expand the partition into the newly gained free space, which VMWare clearly knows about because it shows in yellow as 744 GB.  However, clicking on the new space on the left does nothing, it seems to be unclickable.  The drop down boxes above it are not enabled either.  There seems to be no way to expand this partition.

v1.gif

When connecting directly to the host and running some commands, we see the following:

pastedImage_1.png

v3.png

Any Thoughts?

0 Kudos
MidwestFinishin
Contributor
Contributor

Here is the VD in Dell's OpenManage Server, showing the Size has indeed been expanded to the new capacity.

pastedImage_0.png

0 Kudos
a_p_
Leadership
Leadership

Please run the following two commands, and post their output in a reply. ) please post the text output, rather than a screenshot for better readability).

partedUtil getptbl "/vmfs/devices/..."

partedUtil getUsableSectors "/vmfs/devices/..."

Run the commands for the device/disk itself, i.e. do not append the partition (":3" in this case") to "naa.6d...9d".


André

0 Kudos