AlexSystemEngin
Contributor
Contributor

Loading ESXi installer issue " Relocating modules and starting up the kernel"

Hello Everyone,

We are trying to install ESXi 5.0 on one of our server

We are booting from CD, In "Loading ESXi Installer " screen when everything loads we get a message at the end " Relocating modules and starting up the kernel..." and it freezes here and nothing else happens..   for hours....

I have tried to restart the installation few times and i get same thing.. 

Anyone know what could be the issue?

Attached is a screenshot.

Thank You!

57 Replies
Awdrius
Contributor
Contributor

Same here, could not install ESXi 5.5 on H8DGi-F and was struggling for couple of hours. All my troubles went away after disabling headless ACPI option in BIOS.

shaakz
Contributor
Contributor

Hello and thanks for posting this tip, booting with manual shift+O mode works for me since there is no ACPI option in my bios on x4170 M2.

Altho, i cannot get esxcfg-advcfg -k TRUE ignoreHeadless to work.

Since 5.5 vCLI this is the command i use:

esxcli -s serverip system settings kernel set -s=ignoreHeadless -v=TRUE
It changes the value to TRUE as i can check with kernel list -o IgnoreHeadless

BUT, when i reboot it still doesnt boot until i SHIFT+O and type IgnoreHeadless=TRUE, i check the value again in esxcli and its now FALSE.

That tells me the value is not getting saved when i reboot, got any tips?

0 Kudos
ripeed
Contributor
Contributor

For IBM x3250 M4 I must upgrade UEFI to version JQE150A and newer to install ESXi 5.1 U1.... without that have same message "Relocating modules and starting up the kernel"

0 Kudos
jim_best
Contributor
Contributor

Hi shaakz,

I managed to overcome this issue by issuing the following command in the ESXi local console, as the command mentioned above, esxcfg-advcfg -k TRUE ignoreHeadless, didn't work for me either:

esxcfg-advcfg --set-kernel "TRUE" ignoreHeadless


After restarting the server, the change seems to be persistent and the server itself boots with no problems.


Hope it helps.

0 Kudos
AlexanderCapald
Contributor
Contributor

this error relates to the amount of memory modules being to high.

try installing less than 16gb or ram during the esxi 5.5 install process, then when its all done increase to 64gb.

or

try to use esx4 dvd boot disc as a hardware health check, as that is the full install, version 5 is a cutdown esxi hyperviser, by using esx4 install dvd you can quickly discover any actual hardware issues with your servers, as this dvd contains alot more drivers and is compatable with a higher variety of boards.

then once those are fixed try esxi 5.5 update 1 cd.

0 Kudos
markbulmer
Contributor
Contributor

Dear Alex,

If you are using Virtual Box to install ESXI, make sure that under operating system you choose "Other/Other 64-bit" not "Other/Other"

0 Kudos
imompero
Enthusiast
Enthusiast

Thank you, i am now installing esxi 5.1 u2 on my x3550 after reading your advice and others on here. I disabled virtualization and removed most of my memory.  Before I wasn't able to get pass "Relocating Modules".  Whether i was installing on hard drivers or usb thumb drives.  Working great now, thanks!!!

0 Kudos
sangra
Contributor
Contributor

I got resolved this issue with help of method explain in following link.

http://robwillis.info/2014/01/dell-cs24-esxi-5-5-install-stuck-relocating-modules-and-starting-up-th...

Good luck!

0 Kudos
psychowood
Contributor
Contributor

@sangra Did you try a J1900 board or a different one? I believe the headless option was one of the first tried by most of the J1900 owners Smiley Happy

0 Kudos
ascherz
Contributor
Contributor

Hi All,

I have the similar issue with ESXi 5.5 u2 with Asrock Q2900M board. I know it is not on HCL, but is there any sollution to install it?

I tried headless option, but not helped. Tried with a PCIex16 video card (Radeon HD 6500) but no-go, so it seems not a VGA issue.

in bios settings, there is no any ACPI headless options.

Any idea what sould I do?

Thank you very much

Regards

A.

0 Kudos
zode94
Contributor
Contributor

Hello,

+1 ascherz

I have a Q2900M , installation impossible with ESXi 5.5 and 6.0


Thanks

0 Kudos
cloud47
Contributor
Contributor

Hi, I just had this problem and the fix was to use put the thumb drive in the USB port in the back of the server and boot from Generic USB instead of using the front USB.  I was using the HP custom ESXi 5.1 update 3 on an HP ProLiant DL360 Gen 9. 

0 Kudos
polo939
Contributor
Contributor

0 Kudos
manhattan11
Contributor
Contributor

Sangra advice solved my problem on a brend new HP DL 380 Gen9, thanks a lot

0 Kudos
sp46887
Contributor
Contributor

‌I found a solution to bypass the message "relocating modules ..." on my ASRock N3150, read here:

http://mobiletiger.jorba.de/vmware-esxi-6-0-n3150-itx-intel-celeron-braswell-platform-problem-solved...

0 Kudos
collegeteck
Contributor
Contributor

My Machine: Dell R610 Server

ERROR WHEN LOADNG VMWARE ESXI

“Relocating modules and starting up the kernel”

Issue: I was trying to install VMWare ESXi on my Dell R610 Server. I tried troubleshooting using the headless switches on the install. Checked all my drivers, updated all my firmware and problem still persisted. I was using 8GB Chips in combination of 16GB & 32GB

Solution: I took out all the memory and loaded a 4GB in 1 Bank for each CPU. Installed the Operating System then booted to make sure it worked perfects. Then shutdown the server and adding back my original 2 8GB Chips and worked perfectly.

0 Kudos
rus80280
Contributor
Contributor

in bios find "ioapic 24-119 entries" or something like that, and swich to disabled

0 Kudos
RahulVmware1985
Enthusiast
Enthusiast

Did you tried changing Memory from BIOS and allocate 3GB to server.

3650 X5:

System setting >> Device and IO ports >> MM Config base :: Set it 3 GB or higher.

If found helpfull please mark it as answered Smiley Happy

Rahul

0 Kudos