AlexSystemEngin
Contributor
Contributor

Loading ESXi installer issue " Relocating modules and starting up the kernel"

Hello Everyone,

We are trying to install ESXi 5.0 on one of our server

We are booting from CD, In "Loading ESXi Installer " screen when everything loads we get a message at the end " Relocating modules and starting up the kernel..." and it freezes here and nothing else happens..   for hours....

I have tried to restart the installation few times and i get same thing.. 

Anyone know what could be the issue?

Attached is a screenshot.

Thank You!

57 Replies
RodyMcAmp
Contributor
Contributor

I am having the same issue on my evga x58 classified motherboard with an i7 920, just to get it installed I have a geforce 520 vid card in there but if i ever get it installed i will pull it. I have tried different vid cards on the off chance that, that was the issue, I have also tried intel nic. I am baffeled at this point and am curious if people having this issue are mostly using X58 motherboards or is there somthing else we have in comon. I relize that my motherboard is not on the HCL but it should work.

0 Kudos
LockAze
Contributor
Contributor

Well, I have an IBM X3100 M4 server and I can't seem to figure out why it won't install.. Smiley Sad it just hangs.

0 Kudos
pwoe
Contributor
Contributor

Hi VMware-Community,

we are fighting with a similar issue. We want to run Autodeploy for servers with no video card installed. The deployment ends up with the message "Relocating modules and starting up the kernel" and then follows a reboot.

We were able to fix the issue for a standard installation by editing boot.cfg:

kernelopts runweasel debugLogToSerial=1 logPort=com1

(http://kb.vmware.com/selfservice/microsites/search.do?cmd=displayKC&externalId=1033888)

Unfortunately I didn't find any method to change kernelopts for AutoDeploy. Was anyone able to run AutoDeploy without having a video card installed in the servers?

Best Regards,

Peter

0 Kudos
cutch69
Contributor
Contributor

Have you fix this as i am habing the same issue

0 Kudos
RodyMcAmp
Contributor
Contributor

I have tried the fix in post 22 and I still did not get any further, it is very puzzling.

0 Kudos
JonathonReinhar
Contributor
Contributor

Bingo! Same here with the 1MB vs 8MB. Thanks martin_r!  Damn fancy installer!

0 Kudos
psychowood
Contributor
Contributor

There's a good chance that ESXi 5.1 fixed this problem, if you are having problems with v5.0 .

0 Kudos
RodyMcAmp
Contributor
Contributor

I just tried with 5.1 and got the same error. I have not purchased new hardware yet but I will soon.

the post codes on my motherboard that it locks up at seem to the these.

25 Shadow VBIOS Shadow system/video BIOS
26 Clock Gen Init onboard clock generator and sensor
27 Setup BDA Setup BIOS DATA AREA (BDA)
28 Reserved
29 CPU Speed
detect
Chipset programming and CPU Speed detect

most of the time it will hit 29 wait for a few seconds and then drop to 28.

a few times it would cycle between 25 and 26, and if I leave it on a long time it switches to rotating between 27 and 28, it is a very strange issue. I have 8 computers in my house and this is the only one that will not boot esxi, and ofcourse it is the one i want to run it on.

evga x58 classified e759

intel i7 920

24 gb ram corsair vengence

0 Kudos
MPangaro
Contributor
Contributor

Hey McBain,

Just wondering if you ever got past this. I have the same system.

Thanks,

Matt

0 Kudos
pk8655
Contributor
Contributor

Hello. Did you find resolution for your issue? I have the same system (x3100) and same problem. Thanks

P.s. I'm able to install ESXi 4.1 without problem.

0 Kudos
vlho
Hot Shot
Hot Shot

0 Kudos
RezaFH
Contributor
Contributor

Hello,

I have the same problem with Supermicro X9SCL-F board.

I've searched for Video Memory option in the Bios, but there is nothing like that!

Just this : Boot graphic adapter priority [onboard vga]

any idea ?

0 Kudos
trich2065
Contributor
Contributor

I am having the same issue with 5.1.  I have a proliant ML150 G6 and it is on the HCL list.  I have tried using the VMWare Custom CD from HP - i get further, but still ends with the same message of "relocating modules and starting up the kernel".  The only onboard video options I have are "auto detect or "always enabled".  Tried both settings - same result.  Anyone have suggestions?

0 Kudos
kustomise
Contributor
Contributor

Sorry to bring this up again but I have a similar issue and was hoping someone could help.

i get the same message but in my system there is no option in bios to change onboard video.

we have IBM X3250 M4 which is on the hcl. I have tried both 5 and 5.1

thank you

0 Kudos
Sydman
Contributor
Contributor

Hello all,

I am having the same problem here.

Asus KFSN4-DRE/SAS mobo on BIOS version 1010

No onboard video settings that I can find to change the memory, have tried ESX 4 and 5 with the same issue. Even tried loading Windows Server 2008 and it just reboots after loading the Windows installation files. Tried new hard drive, tried loading from CD-ROM and USB, tried decreasing the RAM.

Anyone have any ideas?


Thanks,

Joe

0 Kudos
kustomise
Contributor
Contributor

Hi Joe,

I never managed to sort this problem, so I gave up in the end. If you manage to get some help and figure it out I would love to hear how you resolved it.

I was going to install windows server back onto the server and try and remotely install it.

0 Kudos
dhilliard
Contributor
Contributor

Hi there.

I'm also running into the same issues as many of you are - "Relocating modules and starting up the kernel"

I'm pretty convinced it is a video memory issue based off most of your responses - however my only options on adjustments of my onboard video memory is Auto, 32mb, 64mb, and up to 1024mb. Nothing close to the 8mb as noted for many. I'm thinking about looking for a video card that might do the trick and disable my onboard video with lack of other options that I can see up to this point. Any recommendations on a PCIe video card that might do the trick?

Also I have to say I really do think this community is great! It's really too bad such a small issue is preventing many of us from booting our systems.

DH

0 Kudos
julioescobar
Contributor
Contributor

Hi kustomise, I think I have the same problem as you, I solved it by disabling the intel virtualization technology from BIOS, then install vmware, and once installed re-enable this option. I' m sorry for my English, is very bad. regards

0 Kudos
Dallo
Contributor
Contributor

I have just been looking into this issue and have found that this may be expected behaviour with some servers which are reporting themselves as "headless" i.e. servers with no video display device either local or remote.

Following startup, if networking is configured, the ESXi host is reachable on the network using Ping, SSH, the vSphere Client, and vCenter Server. Virtual machines can be started and managed normally. Can you check if this is the case?

Some systems which have a video display device can be configured to report themselves as headless via the configuration, usually in the system BIOS. For these systems, it is usually preferable to use a non-headless configuration.

Systems which are known to expose a Headless configuration option in the system BIOS include:

Oracle Sun x5220 - Section 2.3.5.6 of the X5220 Server Service Manual

Oracle Sun x6270 - Section B.2.0.4 of the X6270 Server Service Manual

Oracle Sun x4600 - Section 2.3.5.7 of the X4600 Server Service Manual

For other servers, consult the hardware vendor.

You may also try the following:

If the server hardware platform has a display device but claims to be headless in the ACPI configuration and does not provide a way to configure it in the BIOS, use an advanced VMkernel boot-time configuration option to ignore the ACPI configuration and use the local console anyway.

  • Press Shift+O during startup of an ESXi 5.5 installation.
  • Append the boot option
    ignoreHeadless=TRUE
  • Press the Enter key to continue boot.
  • Once installation is completed, set the VMkernel boot-time parameter in persistent configuration using the command:
    esxcfg-advcfg -k TRUE ignoreHeadless
ekaczmarek
VMware Employee
VMware Employee

Setting the headless option to dis-abled in the (ACPI portion of the ) bios did the trick for me. I was able to get vsphere 5.5 loaded on a legacy AMD system.

Thanks Dallo

0 Kudos