mbartle
Enthusiast
Enthusiast

Lifecycle Manager wants to remove a VIB that is used by HA

I have an issue that i'm not sure if this is normal or not.  We are running ESXi 7.0.1 U1d that we upgraded from 6.7 using the traditional ISO / baseline.

I am wanting to bring these up to 7.0.2 U2c using the new image based method.  When i start the process and select the image profile plus the Dell EMC addons, I get this message at the top :

Identified standalone vib(s) vmware-fdm 7.0.2-18356314 belonging to vSphere FDM 7.0.2-18355786 solution component.

When I save and have it validate the image against the HCL, it comes back with :

The following VIBs on the host are missing from the image and will be removed from the host during remediation: vmware-fdm(7.0.2-18356314).

This VIB seems to be the HA agent.  If it removes it during the remediation, will it re-install it again when the host exits maintenance mode ? How else will it be able to be a cluster member ?

 

Screen Shot 2021-09-10 at 11.16.06 AM.png

9 Replies

FDM Agent will be installed by vCenter, so I think that you should test and try it on one of hosts for sure, before upgrading whole cluster.

-------------------------------------------------------------------------------------
Davoud Teimouri - https://www.teimouri.net - Twitter: @davoud_teimouri Facebook: https://www.facebook.com/teimouri.net/
0 Kudos
Srijithk
Enthusiast
Enthusiast

you may proceed with it

vcenter pushes an FDM vib once the host exits maintenance mode and then HA gets reconfigured 

if you are facing any issues take an ssh session to host and confirm that fdm isn't installed already

esxcli software vib list |grep fdm

if it isn't refer --> https://kb.vmware.com/s/article/2011688 to get the fdm installed manually

Thanks,

Srijith

SureshKumarMuth
Commander
Commander

Have you tested it ? Did you notice any issue with fdm after updating the nodes ?

Regards, Suresh https://vconnectit.wordpress.com/
0 Kudos
JGO96
Contributor
Contributor

I second this - Has anyone tested their environment with the vmware-fdm(7.0.3-19192831) removed and is all working fine?

0 Kudos
MyUser2
Contributor
Contributor

Has anyone tested their environment with the vmware-fdm(7.0.3-19192831) removed and is all working fine?

0 Kudos
Aaron-csp
Contributor
Contributor

Same question; we are currently running the latest ESXi 7.0.3 Build 20842708.

Originally installed using the customized HPE ESXi ISO, always updated using Baselines.

Now wanting to switch to the image based method, as baselines are marked as deprecated in 8.0+.

Our cluster has 17 hosts right now, DRS and HA is enabled. We cannot afford to lose HA availibility due to removed vsphere-fdm.

Building the image using the latest ESXi Release (7.0 U3i - 20842708), adding the HPE Customization for HPE Servers in its latest release (703.0.0.11.1.0-25), additionally replacing the VMware-VM-Tools component with the latest async release in the Host-Image, so that 12.1.0 will be replaced with 12.1.5.

2023-01-02_13-09-20-948_6dKj22.png

When I check the compliance, everything looks fine BUT the removal of 'vsphere-fdm' scares me, so right now I don't finish the process of setting up the image based process, as there is no way back to using baselines once the switch is made.

I read a lot of documentation from docs.vmware.com, I searched a lot of third party sites, but I didn't find an answer to this question.

After switching to image based updating, when the vsphere-fdm gets removed: will it get reinstalled once the host is updated with the newly created image? Another question: even IF it works this way, will the host still be "compliant" with the image after vsphere-fdm got re-installed? Or will it report a mismatch, because there would be an additional package installed which is not part of the manually defined image?

Some clarification would be nice. Thanks in advance!

0 Kudos
depping
Leadership
Leadership

No worries, it will work just fine. Done this dozens of times.

Aaron-csp
Contributor
Contributor

Thank you for the reassurance; I just switched to the image based solution and remediated the first few hosts one by one and as you said, everything works just fine.

0 Kudos
JGO96
Contributor
Contributor

I can also confirm we have proceeded with this in our production environemnt and HA still works fine

0 Kudos