str1ker
Contributor
Contributor

Issue with smx-providers on VMware 6.5 U3

Hi VMware-Folks,

I ran into the following issue and want to try to get the VMware-View of the problem.

Maybe someone has run into the same issue:

We have serveral HPE DL360 Gen10 Servers, installed with the HPE cursomized Image: VMware-ESXi-6.5.0-Update3-14990892-HPE-Gen9plus-650.U3.10.5.0.67-Dec2019.iso

All share the same Issue: If we try to poll Status via WBEM, nothing returns, as if the package is not installed.

I could narrow it down to the following:

The WBEM-Provider List shows a stange ".#vmw_smx-provider" entry:

esxcli system wbem
provider list

Name                Enabled  Loaded

------------------  -------  ------

.#vmw_smx-provider     true    false

sfcb_base              true    true

vmw_base               true    true

vmw_hdr                true    true

vmw_hhrcwrapper        true    true

vmw_iodmProvider       true    true

vmw_kmodule            true    true

vmw_omc                true    true

vmw_pci                true    true

vmw_smx-provider       true    true

vmw_vi                 true    true

Looking at /var/lib/sfcb/registration gives:

-rw-rw-rw-    1 root     root           112 Sep  3 13:38 loaded
drwxr-xr-x    1 root     root           512 Sep  3 13:37 repository
-r--r--r--    1 root     root          3513 Nov  1  2019 sfcb_base-providerRegister
-r--r--r--    1 root     root          4307 Nov  1  2019 vmw_base-providerRegister
-r--r--r--    1 root     root           374 Nov  1  2019 vmw_hdr-providerRegister
-r--r--r--    1 root     root           897 Nov  1  2019 vmw_hhrcwrapper-providerRegister
-r--r--r--    1 root     root          4220 Nov  1  2019 vmw_iodmProvider-providerRegister
-r--r--r--    1 root     root           164 Nov  1  2019 vmw_kmodule-providerRegister
-r--r--r--    1 root     root         15650 Jun 21  2019 vmw_omc-providerRegister
-r--r--r--    1 root     root          1550 Nov  1  2019 vmw_pci-providerRegister
-r--r--r--    1 root     root          1308 Sep  3 13:38 vmw_smx-provider-providerRegister
-r--r--r--    1 root     root          2898 Mar 15  2018 vmw_vi-providerRegister

However there is the hidden file mentioned above:

ls -l /var/lib/sfcb/registration/.#vmw_smx-provider-providerRegister
-r--r--r-T    1 root     root         77881 Aug  9  2019 /var/lib/sfcb/registration/.#vmw_smx-provider-providerRegister

This file shares the same bytesize on Gen9 Servers and obviously contains the HPE specific data.

If I overwrite the vmw_smx-provider-providerRegister with the contents from .#vmw_smx-provider-providerRegister the polling works as intended.

Until the next reboot or even just until restart of the mangagement network ...

I found: https://www.virtuallyghetto.com/2011/08/how-to-persist-configuration-changes-in.html

.. and tried to do use the Sticky Bit, but nothing kept the file from beeing overwritten with the default(?) version.

I also tried to downgrade the smx-provider package up to three versions and downgraded the whole management bundle in a separate attempt.

Nothing helped.

Gen9 Systems with the same image do not have that Issue at all. (as mentioned: there is just one vmw_smx-provider-providerRegister with the corrent and same bytesize as the .#vmw_smx-provider-providerRegister Version on the Gen10 systems)

Does someone have an Idea how to replace the vmw_smx-provider-providerRegister with the correct version and stick that version into the bootbank ?

Upgrading to 6.7 Ux will happen, but is currently not an option for a quick fix.

The mentioned systems are the only Gen10 servers in this environment.

0 Kudos
4 Replies
str1ker
Contributor
Contributor

As an update:

I could not find a solution to this. As mentioned before, I tried downgradind to the following versions:

HPE_bootbank_smx-provider_650.03.14.00.3-4240417
HPE_bootbank_smx-provider_650.03.15.00.4-4240417

.. without any change.

The Version from the Image was

HPE_bootbank_smx-provider_650.03.16.00.4-4240417

I then tried the HPE_bootbank_smx-limited_650.03.16.00.1-4240417

and the .#* Entry is gone:

esxcli system wbem
provider list

Name                Enabled  Loaded

------------------  -------  ------

sfcb_base              true    true

vmw_base               true    true

vmw_hdr                true    true

vmw_hhrcwrapper        true    true

vmw_iodmProvider       true    true

vmw_kmodule            true    true

vmw_omc                true    true

vmw_pci                true    true

vmw_smx-limited        true    true

vmw_smx-provider       false   true

vmw_vi                 true    true

The small / default  vmw_smx-provider-providerRegister is this there, but is not used in this scanario:

ls -l /var/lib/sfcb/registration

total 100

-rw-rw-rw-    1 root     root           128 Sep  7 13:39 loaded

drwxr-xr-x    1 root     root           512 Sep  7 13:38 repository

-r--r--r--    1 root     root          3513 Nov  1  2019 sfcb_base-providerRegister

-r--r--r--    1 root     root          4307 Nov  1  2019 vmw_base-providerRegister

-r--r--r--    1 root     root           374 Nov  1  2019 vmw_hdr-providerRegister

-r--r--r--    1 root     root           897 Nov  1  2019 vmw_hhrcwrapper-providerRegister

-r--r--r--    1 root     root          4220 Nov  1  2019 vmw_iodmProvider-providerRegister

-r--r--r--    1 root     root           164 Nov  1  2019 vmw_kmodule-providerRegister

-r--r--r--    1 root     root         15650 Jun 21  2019 vmw_omc-providerRegister

-r--r--r--    1 root     root          1550 Nov  1  2019 vmw_pci-providerRegister

-r--r--r--    1 root     root         31636 Aug  9  2019 vmw_smx-limited-providerRegister

-rw-r--r--    1 root     root          1308 Sep  7 13:39 vmw_smx-provider-providerRegister

-r--r--r--    1 root     root          2898 Mar 15  2018 vmw_vi-providerRegister

As a result, only a subset of WBEM date is available, which is better then nothing.

According to the Date, the File just gets overwritten, and the (correct) version from HPE is backed up on every reboot. Isn't there a way to forcefully prevent that ?

I have beed digging through the change logs of all update released, but this issue is not mentioned (just memory leaks etc.).

0 Kudos
alexim12
Contributor
Contributor

When restarting ESXi management agents on HP ProLiant G5, G6 ... In this case you need to upgrade to ESXi 5.5 Update 3 and upgrade to ...telltheram

0 Kudos
rooter344
Contributor
Contributor

In the recently released VMware ESXi 6.7, Patch Release ESXi670-202008001, in the Resolved issues sections, you will find: "PR ... at least 24 hours: To disable a provider, e.g. the smx-provider, run the following command  ... 
 
0 Kudos
hattiemercy04
Contributor
Contributor

Issue with smx-providers on VMware 6.5 U3. Hi VMware-Folks,. I ran into the following issue and want to try to get the VMware-View of the running VMware vSphere 5.5 U3, vSphere 6.0 U2 or vSphere 6.5 This issue is corrected by upgrading HPE Insight Management ... 

https://surveyz.onl/www-talktodunelm-co-uk/

0 Kudos