JLOAIZA
Contributor
Contributor

Is anyone seeing this odd files that seem to be hard to remove from the /locker in ESXi

So while in the midst of upgrading my ESXi 6.5u1 to 6.7u2, I ran into this on many of my hosts. "The system has insufficient locker space for the image profile." While I had to try different things on a case by case basis to get to ESXi 6.7u2. In the majority of the hosts I kept seeing the following in images below. In some cases I was able to delete everything in the /locker folder in some I'm not. I'm only able to remove enough stuff so that I can copy over the packages and var folders which should be the only things in here. Just wondering if anyone else has ran into this and can shed some light. I'm also getting this on some hosts when I try the following command to remove everything in folder (rm -rf *)

pastedImage_3.png

pastedImage_4.png

pastedImage_2.png

0 Kudos
2 Replies
pragg12
Hot Shot
Hot Shot

Hi,

This is indeed strange and I haven't faced this before. Files like these shouldn't exist. If I had to guess, these files seem to be result of some form of ESXi OS corruption since generic commands such as ls is giving error here which shouldn't happen.

Does these garbage files persist after ESXi is rebooted ?

Is the hardware firmware updated and in line with ESXi drivers ?

Power off ESXi and remove power cable for 10 mins. If ESXi boot is through SD card, re-seat it. Re-seat every memory modules as well.

If none of this helps in any way, it would be best to involve VMware support since it would be wise to get this sorted out to make sure it doesn't appear again in future.

Consider marking this response as "Correct" or "Helpful" if you think my response helped you in any way.
0 Kudos
JvodQl0D
Enthusiast
Enthusiast

i realize this is old now, but anyone finding this again, this was the best resource that has helped me at least twice for the same issue:
https://tcrum.net/esxupdate-error-code-15

i did a rm -rf /store/* and rebooted. it worked.
use at your own discretion, this is probably not the best solution, but a bunch of useless corrupted folders suck too.