gesturgis
Enthusiast
Enthusiast

Intel i350-T4 not recognized

Hey folks,

Just installed a new NIC, Intel i350-T4.  esxcfg-nics -l does not show the NIC, but lspci shows this:

0e:00.0 Ethernet controller: Intel Corporation Unknown device 1521 (rev 01)
0e:00.1 Ethernet controller: Intel Corporation Unknown device 1521 (rev 01)
0e:00.2 Ethernet controller: Intel Corporation Unknown device 1521 (rev 01)
0e:00.3 Ethernet controller: Intel Corporation Unknown device 1521 (rev 01)

Any suggestions for getting this recognized by ESX?

Thanks,

Grant

0 Kudos
10 Replies
john23
Commander
Commander

From vmware vSphere compatibility guide:

This driver is inbox only on esxi 5.0 and onwards.

For 4.0 its a ansyc driver.

http://www.vmware.com/resources/compatibility/detail.php?deviceCategory=io&productid=19798&deviceCat...

Thanks -A Read my blogs: www.openwriteup.com
gesturgis
Enthusiast
Enthusiast

Thanks John.

I downloaded igb-3.1.17-455019.zip and upzipped it.  Then I attempted:

esxupdate --bundle=igb-3.1.17-offline_bundle-455019.zip update

but that failed with this:

error: Failed acquiring release file for 'metadata5183719994545526357':                                                             
error: file:///var/cache/esxupdate/metadata5183719994545526357/repodata/repomd.xml: File not found for validation
Encountered error MetadataFormatError:
The error data is:
   Filename    - None
   Message     - Failed scanning package data: Downloading metadata failed.
   Errno       - 5
   Description - The format of the metadata is invalid.

Any ideas on what I am doing wrong?

0 Kudos
john23
Commander
Commander

which location you downloaded the bundle...

if its vmfs give abolute path...means /vmfs/volumes/<datastore name> /bundle.zip

give a try without unzip as well

esxupdate --bundle igb-3.1.17-455019.zip update...

Thanks -A Read my blogs: www.openwriteup.com
0 Kudos
gesturgis
Enthusiast
Enthusiast

The files are in my home directory.  I tried with absolute path, same problem.  Tried with with the original zip file igb-3.1.17-455019.zip and same problem.

0 Kudos
john23
Commander
Commander

can you copy in vmfs data store or root and try (its a guess) ,as well check the disk space / partition.

check this kb kb.vmware.com/kb/1032936

Thanks -A Read my blogs: www.openwriteup.com
0 Kudos
gesturgis
Enthusiast
Enthusiast

I was working off of that KB article.  Unfortunately, moving the ZIP file to the VMFS datastore produces the same result.

0 Kudos
john23
Commander
Commander

what about space.. /tmp and /var...enough space is avialable...

check firewall as well (it should not matter in offline case ..i think so ) but still down and give a try..

Thanks -A Read my blogs: www.openwriteup.com
0 Kudos
gesturgis
Enthusiast
Enthusiast

1.5G available, I would hope that's enough.

0 Kudos
gesturgis
Enthusiast
Enthusiast

Turns out I had the wrong driver.  The correct one is:

INT-intel-lad-ddk-igb-3.2.10-offline_bundle-493750.zip

Found here:

     https://my.vmware.com/web/vmware/details?downloadGroup=DT-ESXI40-Intel-igb-3210&productId=136

Who knew?  (VMware support did).


0 Kudos
Chwahu
Contributor
Contributor

I installed the driver, and all is working fine.  However, when I attempt to put a second card in to the ESXi server, neither card works?

0 Kudos