Highlighted
Contributor
Contributor

IBM usb memory vmware esxi 4.1... boot issue ?

I have licensed my x3400 server with vSphere 4.1 essent. plus license and got the the hypevisor with an usb memory key.

My question is , do I need to boot with the ESXi 4.1 cd and install ESXi on the usb stick first and then boot with it, or it is preinstalled alredy,

because when I plug the stick in the server and set the boot options in the bios to usb storage or embedded hypervisor it won't boot from it.

Am I doing something wrong , thanks in advance.

0 Kudos
15 Replies
Highlighted

Welcome to the VMware Communities forums.  You should be able to boot from the USB key and be ready to configure ESXi.  If you plug the key into another machine you should see a partition layout similar to this.  If you don't then perhaps there is an issue with the key.

0 Kudos
Highlighted
Contributor
Contributor

Tnx for the fast reply. When I plugged it in my W7 box I got 2GB raw parttion with no files on it?

Fabric error or do I have to install ESXi on it ?

0 Kudos
Highlighted

What part number does the key have?  You could go ahead and install ESXi onto it or get them to replace it.

0 Kudos
Highlighted
Immortal
Immortal

have a look at this tutorial. you can install ESXi on the drive.

http://www.vladan.fr/how-to-install-esxi-40-on-usb-memory-key/

0 Kudos
Highlighted
Contributor
Contributor

The labels on it are like FRU 46M675  then a long serial and then DMK1048U06. I think it should have preinstaled hypervisor.

0 Kudos
Highlighted

Probably would be the safest best to get it replaced.

0 Kudos
Highlighted
Contributor
Contributor

I have pluged it in inside the server on the motherborad usb key slot, and selected the embededd hypervisor boot and usb storage but no luck.

Will try to replace it. Has it happened to someone before? 

0 Kudos
Highlighted

Not that I've heard of.  Perhaps it was skipped during the imaging process - perhaps it's defective.

0 Kudos
Highlighted
Contributor
Contributor

I've called the local IBM support team, they will contact me in 24hr and then I'll see if it is defective. If my W7 recognized it as RAW empty partition I think it didn't process the image in factory, don't believe that they would sell me the product and after that I have to install ESXi myself, other way I could buy and empty stick and do it myself.

Hear soon.

0 Kudos
Highlighted
Contributor
Contributor

Hi,

Juste to make you feel less alone, I have a "similar" problem...

Server IBM x3550 M3 and USB key hypervisor.

When I try to boot on the key it says "disk error"

And when I try to read the key in Windows7, it's empty ! :smileylaugh:

I'll use the CD...

Good luck !

0 Kudos
Highlighted
Contributor
Contributor

Hi,

Same problem here.

The setup is IBM x3650 M3. It comes with an optional "IBM USB MemKey" PN: 41Y8287.

I Boot with VMware CD to install on the Memkey, no problem, i can see it and install ESXi.

But server don't boot on it, even if i add in the boot manager the "USB Storage"

Anyone have a solution ???

Any help appreciated.

Best Regards.

0 Kudos
Highlighted
Immortal
Immortal

Double check your BIOS boot settings.

Reinstall ESXi.

If you have a startup option to bring up a boot menu to select a temporary boot device try selecting the USB device.

Call IBM support.

-- David -- VMware Communities Moderator
0 Kudos
Highlighted
Enthusiast
Enthusiast

you may need to add the Legacy Only Boot Options in the UEFI.

http://communities.vmware.com/thread/291293?tstart=0

0 Kudos
Highlighted
Contributor
Contributor

Thank you DSTAVERT and SurfControl. I have seen usb storage but not embedded hypervisor. I must clean my eyes !!

Thanks a lot.

0 Kudos
Highlighted
Hot Shot
Hot Shot

I am configuring an IBM HS23 with an usb key I installed the latest ESXi version. I had to select Embbeded Hypervisor option in boot to get it up and running since the USB Storage option was not working

0 Kudos