Highlighted
Contributor
Contributor

Huawei USB Modem on an ESXi 5 Host attaches as a SCSI device and returns NSIS error on intallation

We are attempting to use a Huawei USB Modem for one of our virtual servers, running Windows Server 2008 R2 Standard, on a HP Proliant DL 380 G7 running VMWare ESXi, 5.1.0, 1065491.

The USB Device only attaches as a SCSI device, despite having followed the guidelines outlined in this link VMware KB: USB support in ESXi/ESX 4.1 and ESXi 5.x .

We are only able to add the USB Controller, but the USB Device is not available, but searching for it under the SCSI devices, it appears as CD / DVD HUAWEI device, which is the route we took, and after adding it, the exe does launch under Drive E, but executing it returns the error message NSIS Error with the additional information that "Installer integrity check has failed. ........ " and the link http://nsis.sf.net/NSIS_Error

The problem I think emanates from the USB Device not being able to get added as a USB Device, like it would on a laptop.

Kindly assist on getting the USB Device to get added as a USB Device to this vm server.

0 Kudos
19 Replies
Highlighted
Enthusiast
Enthusiast

Hi.

You need to switch modem to 3g modem only.

It can be done by AT command

0 Kudos
Highlighted
Contributor
Contributor

0 Kudos
Highlighted
Contributor
Contributor

If  you  have  huawei or zte usb modem - and cannot connect  it to vmware -follow  next steps

1 install  modem software  and drivers on real computer .

2 install modem software and drivers  on virtual machine  via  mapping scsi cdrom .!!!!!( do it obligatorily).(ну и слово блин ...)

3 connect modem to real computer ,install modem software and drivers , open  hardware by  right click  in "computer", open com and lpt ports . remember com port -which usb modem is connected.

4 open hyperterminal or  putty, connect to port  which modem installed  and type this command  AT^SETPORT="A1,A2;1,2,3," - this command set you modem in "modem only" mode

if you have a  huawei modem e402(same with me) or newer, this command  IS NOT WORKING . you need type command AT^SETPORT="FF;1,2"

4 unplug your modem, wait  few  seconds  and plug it to vmware esxi . wmware detect it  as on screenshothuawe1.GIF

if  you carefully read step 2  you'r modem will be  detecting  automatically.

5  PS. ZTE modems have another  AT command system  with HUAWEI- to switch ZTE in "modem only" mode you  need  to type this commands AT%USBMODEM=0

if you   modem  say error and can't  switch to modem mode - type this commands

AT+ZCDRUN=E

AT+ZCDRUN=8

unplug, wait, plug to esxi

vmware will be  recognize you modem as on screenshot huawey.GIF

thats  all.

0 Kudos
Highlighted
Contributor
Contributor

Hi,

I cant connect usb device white putty, can you give us more informatin about this step?

Thnaks.

0 Kudos
Highlighted
Contributor
Contributor

give me screenshot of you com\lpt devices

2014-02-26 18:35 GMT+04:00 nfserd <communities-emailer@vmware.com<mailto:communities-emailer@vmware.com>>:

VMware Communities<https://communities.vmware.com/index.jspa>

Huawei USB Modem on an ESXi 5 Host attaches as a SCSI device and returns NSIS error on intallation

created by nfserd<https://communities.vmware.com/people/nfserd> in VMware ESXi 5 - View the full discussion<https://communities.vmware.com/message/2350375#2350375>

0 Kudos
Highlighted
Contributor
Contributor

post  screenshot  with you com\lpt devices

0 Kudos
Highlighted
Contributor
Contributor

http://i.hizliresim.com/xBgM0v.jpg

0 Kudos
Highlighted
Contributor
Contributor

can you    run  step1 ?- install  modem software  and drivers on real computer .?

i can\t see modem device\s on  you computer/

  first,  you  need install  software and drivers of  your modem  on  real computer..

after installing drivers  you hardware seems like this  zte2.GIF

look   for com3 and com4 ports, com1  and com2 is standart motherboard bios ports

0 Kudos
Highlighted
Contributor
Contributor

I installed modem real pc, its worked well. but i cant see under the com/lpt. Tried 3 diffrent computer, one of windows 7.

0 Kudos
Highlighted
Contributor
Contributor

Hi GardenBear,

How can i access the USB stick via putty? When i try to use putty i cannot connect to the said device.

Do we need another device to connect to the said usb device?

0 Kudos
Highlighted
Contributor
Contributor

choose Serial   and choose COM1  or COM2  etc.

0 Kudos
Highlighted
Contributor
Contributor

Hi GardenBear,

This is my setup when i try to access my USB Broadband stick.

I have followed your instructions but still i cannot connect via putty.

0 Kudos
Highlighted
Contributor
Contributor

please post  screenshot  with  you  usb and com\ltp devices installed in you  computer

0 Kudos
Highlighted
Contributor
Contributor

Hi GardenBear,

Here it is.

3.PNG

4.PNG

0 Kudos
Highlighted
Contributor
Contributor

My setup.

DSC_1454.jpg

0 Kudos
Highlighted
Contributor
Contributor

Upon accessing via putty, this error pops up.

putty.PNG

0 Kudos
Highlighted
Contributor
Contributor

oh.  you model of  usb  stick is different  with my huawei modem

give me plz full name of you usb modem

0 Kudos
Highlighted
Contributor
Contributor

0 Kudos
Highlighted
Contributor
Contributor

i have same issue , Huwaei usb modems not recognize as USB devices or even show at Directpath I/O list

Model E180 and set as modem only
i mentioned here

huwaei usb modem not detect by esxi

0 Kudos