boeggild
Contributor
Contributor

HttpNFC service disabled - missing configuration

Hi everyone.

After upgrading from 6.5 to 6.7 our host displays the above error in vCenter. Everything seems to work fine, but can't make to error disappear.

I can't seem to find the service under "services", so I can enable/configure it.

Any help is much appreciated.

Kindly

Kasper

2 Replies
smickel
VMware Employee
VMware Employee

Hi,

bit late but maybe it helps someone else.

Seems like the NFC config lines are missing in /etc/vmware/vpxa/vpxa.cfg on your ESXi. Please check if the following lines are in there and if not, add them.

- Place ESXi in Maintenance Mode

- Edit /etc/vmware/vpxa/vpxa.cfg and add the following lines:

<httpnfc>

<accessMode>proxyAuto</accessMode>

<enabled>true</enabled>

</httpNfc>

- Stop and start the vpxa service:

/etc/init.d/vpxa stop

/etc/init.d/vpxa start

- Disconnect and reconnect ESXi in vCenter

- Exit Maintenance mode

Now it should work.

/Stefan

0 Kudos
ViennaAustria
Contributor
Contributor

Thank you for the solution! Hoverver...

...it has to be

<httpNfc>

  <accessMode>proxyAuto</accessMode>

  <enabled>true</enabled>

</httpNfc>

...and you don't have to "append" it after all the existing lines, but insert it before the last line </ConfigRoot>.

Result should be:

<ConfigRoot>

  ...

  <httpNfc>

    <accessMode>proxyAuto</accessMode>

    <enabled>true</enabled>

  </httpNfc>

</ConfigRoot>

0 Kudos