IT_Architect
Enthusiast
Enthusiast

How do I set up ESXi 5.1 and FreeBSD to use VMXNET 3?

Jump to solution

I've installed the tools, but how do you get FreeBSD to work with the new VMXNET 3?  When I do the drop down in settings, the latest one shown there is VMXNET 2.  What I did find was to change ifconfig_em0 to ifconfig_vmx3f0 to use VMXNET 3.

Thanks!

0 Kudos
1 Solution

Accepted Solutions
aaronwsmith
Enthusiast
Enthusiast

What version of FreeBSD?  Check the compatibility matrix to ensure it's fully supported by ESXi 5.1, including VMXNET3:

http://www.vmware.com/resources/compatibility/vcl/result.php?search=FreeBSD&searchCategory=Guest+OS

For example, FreeBSD 7.4 does not support VMXNET3 under ESXi 5.1:

http://partnerweb.vmware.com/comp_guide2/detail.php?deviceCategory=software&productid=17579&supRel=7...

In contrast, FreeBSDE 9.0 supports VMXNET3 under ESXi 5.1:

http://partnerweb.vmware.com/comp_guide2/detail.php?deviceCategory=software&productid=17596&supRel=1...

Also, what version is the virtual hardware running this VM?  VMXNET3 is available in v7 and later:

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=100180...

View solution in original post

0 Kudos
5 Replies
aaronwsmith
Enthusiast
Enthusiast

What version of FreeBSD?  Check the compatibility matrix to ensure it's fully supported by ESXi 5.1, including VMXNET3:

http://www.vmware.com/resources/compatibility/vcl/result.php?search=FreeBSD&searchCategory=Guest+OS

For example, FreeBSD 7.4 does not support VMXNET3 under ESXi 5.1:

http://partnerweb.vmware.com/comp_guide2/detail.php?deviceCategory=software&productid=17579&supRel=7...

In contrast, FreeBSDE 9.0 supports VMXNET3 under ESXi 5.1:

http://partnerweb.vmware.com/comp_guide2/detail.php?deviceCategory=software&productid=17596&supRel=1...

Also, what version is the virtual hardware running this VM?  VMXNET3 is available in v7 and later:

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=100180...

0 Kudos
IT_Architect
Enthusiast
Enthusiast

I am doing FreeBSD 9.1 64.

Your link on VM hardware version got my attention.  I upgraded the hardware version and VMXNET 3 is now an option.

The new tools are already installed.  Perhaps all I need to do is change the driver in the rc.conf?

0 Kudos
aaronwsmith
Enthusiast
Enthusiast

I think at this point you now need to add a new NIC that is VMXNET3, then see if FreeBSD picks up on it and assigns the corresponding driver as you would expect.  Then transfer your IP settings to the new adapter and remove the original NIC.  From what it sounds like in your original post, you tried to do something within the OS originally to try and trick the adapter ID to look like a VMXNET3 device ("ifconfig_em0 to ifconfig_vmx3f0")?

IT_Architect
Enthusiast
Enthusiast
From what it sounds like in your original post, you tried to do  something within the OS originally to try and trick the adapter ID to  look like a VMXNET3 device ("ifconfig_em0 to ifconfig_vmx3f0")?

I didn't try it then because the vmnet3 version wasn't available to select from the drop-down.  I was running version 7 of the hardware, and FreeBSD 9.x, so I thought I should be good to go.  What I learned from your post is that the stars that need to be aligned perfectly for the vmxnet3 to show, and you provided the references necessary to create the proper matrix to make that happen.  Apparently there is no published matrix other than to read the different combinations in the docs to find one that allows vmnet3.  For FreeBSD that turned out to be latest VMware tools, FreeBSD 9.x, and the latest VMware hardware version.  Once these were properly aligned, the drop-down displayed vmxnet3 as a selectable option.  After that, I made the ifconfig changes to the rc.conf, and everything worked perfectly.

What triggered it to work for me was upgrading from hardware version 7 to 9.

0 Kudos
aaronwsmith
Enthusiast
Enthusiast

Awesome!  I haven't used FreeBSD so I'm not familar with what needs to be done within the Guest OS.  Glad you're all set.