osdesent
Contributor
Contributor

How can I change the VM adapter from E1000E to VMXNET3 in vCenter

Hi Folks

I'm trying to change the VM's adapter from E1000E to VMXNET3 however in edit sections from vCenter does not allow me to change it, and if I create a new adpater it doesn't show it as an option

pastedImage_0.png

Tags (1)
0 Kudos
5 Replies
scott28tt
VMware Employee
VMware Employee

These may help:

Change network adapter from E1000 to VMXNET3 with ESXi in 5.0

VMware Knowledge Base


-------------------------------------------------------------------------------------------------------------------------------------------------------------

Although I am a VMware employee I contribute to VMware Communities voluntarily (ie. not in any official capacity)
VMware Training & Certification blog
0 Kudos
Alex_Romeo
Leadership
Leadership

Hi,

To change the setting to "VMXNET3" the virtual machine must have the vmware tools installed and must be turned off.

ARomeo

Blog: https://www.aleadmin.it/
0 Kudos
IRIX201110141
Champion
Champion

Looking to the name of the VM i assume its a virtual ESXi?  Yes i read about that that you can use VMXNET3 for a ESXi VM but i dont remember any details because i dont have a need for.

Regards,
Joerg

0 Kudos
NathanosBlightc
Commander
Commander

You can change this directly from the ESXi host web interface when the VM is power-off, or via modifying details of the VMX file, associated with that VM.

Please mark my comment as the Correct Answer if this solution resolved your problem
rwk1982
Enthusiast
Enthusiast

Hello!

You cannot change the Type of the NIC in the GUI. Here you can only delete it and add a new one with the correct type but this will also genereate a new MAC Adresse for your VM. For changing the NIC Type and preserve the MAC Address i always use PowerCLI/PowerShell -> PowerShell Gallery | VMware.PowerCLI 12.0.0.15947286

Open PowerShell and install the PowerCLI Modules:

Install-Module -Name VMware.PowerCLI

Now you can connect to your vCenter with:

Connect-VIServer -Server yourvcenter.fqdn

And change the NIC Type of your VM (the VM must be PoweredOff) - in your case:

Get-VM -Name SDWAN_vESXi | Get-NetworkAdapter | Set-NetworkAdapter -Type Vmxnet3

Hope this helps a little bit

Drink coffee.. Do stupid things faster with more energy...