VMware Cloud Community
ceemour
Enthusiast
Enthusiast

Hot backups of Windows 2008 r2 with vss quiescing

Apparently this is a feature of 4.1.

I have a windows 2008 r2 x64 vm that I am trying to hot backup using vcb.

I am getting a failure

Error: Failed to open the disk: NBD_ERR_GENERIC

when i try to run the command

vcbMounter.exe -h esxhostname -u root -p password -a name:vmname -r c:\backup -t fullvm -m nbd -M1

esxi 4.1, vcb Version 1.5.0.5584 (build-226297), iscsi san, vm with latest vmware tools installed including vss driver

running it with -m san works fine, running it whilst the vm is off with -m nbd also works fine

Has anybody seen this issue or has an inkling what could be the issue.

Regards

Reply
0 Kudos
2 Replies
ceemour
Enthusiast
Enthusiast

NM I appear to have found the answer.

http://www.vmware.mobi/support/vsphere4/doc/vsp_vcb_15_u2_rel_notes.html

New: VCB file-level mount of Windows Server 2008 using NBD transport mode fails with an Disk library failed (NBD_ERR_GENERIC) error

When the disk.EnableUUID parameter in the virtual machine settings is set to True on a Windows Server 2008 virtual machine, the VCB file-level mount using NBD transport mode will either fail with a Disk library failed (NBD_ERR_GENERIC)error or might stop responding, and the vcbMounter command does not run.

Workaround: Set the disk.EnableUUID parameter in the virtual machine settings to False by performing the following steps:

a) Power off the Windows Server 2008 virtual machine through vSphere Client.

b) Click Settings > Options >General > Configuration Parameters.

c) Set disk.EnableUUID to False.

d) Save the settings.

e) Power on the virtual machine.

Reply
0 Kudos
mrjlturner
Contributor
Contributor

Guys,

There is another thread here http://communities.vmware.com/message/1627497 discussing the same issues. You may want to have a look...no solutions as of yet...but hopefully progress as there are a few VMware support tickets open on the issue...

Thanks,

-mrjlturner

Reply
0 Kudos