csaglamoz
Contributor
Contributor

Host and Storage Connection Issue

We have 2 SAN Fabrics . Each of them have 3 x Brocade 6510 48 port SAN Switches.

From every controllers of storages there are 4 or 6 ports connected to one of these switches (central switch). The other 2 switches connected to this central switch with 6 x 8G Trunk ISL Port. All two fabrics have same design.

All hosts have dual HBA and one of the ports connected to Fabric A and the other one is connected to Fabric B.

There is a simple soft zoning. Server WWN's are put on "Servers" alias and each storage WWN's are put on it's own alias (In example "EMCVNX5400"). Each zone has "Servers" alias and one storage alias like "EMCVNX5400".

All hosts running VMware Esxi 5.5. All switches running FOS v7.0.2c .

The problem is some of the hosts can see storage LUNs and some of them can't. I am able to send ping from central switches to each WWN of the host which can't see LUNs. I also tried to restart host but not worked.

I couldn't find what the problem is. Any opinions?

0 Kudos
7 Replies
a_p_
Leadership
Leadership

Server WWN's are put on "Servers" alias and each storage WWN's are put on it's own alias (In example "EMCVNX5400").

You should consider to reconfigure zoning. EMC's recommendation (actually the only zoning which allows features like "SAN Copy") is a single-initiator/single-target zoning. If you don't need features which require this kind of zoning, you may also go with a single-initiator/multiple-target zoning. However, having multiple initiators in a single zone is something you should avoid.

Anyway, zoning is only one step in presenting LUNs to a target. Did you also double-check that the initiators are properly registered with the storage system, and that the Storage Group(s) contain all ESXi hosts as well as the LUNs?

André

0 Kudos
csaglamoz
Contributor
Contributor

Yes, All initiators registed to storage system. When I connect a host directly to the central switch or directly to the host it works.

I also tried to disable all zoning but it doesn't work.  I checked fabrics again and I couldn't find any problem. It seems issue happens on hosts connected to cascaded switches.

0 Kudos
a_p_
Leadership
Leadership

In this case you may want to double-check that the edge switches are properly joined to the fabric (e.g. each switch has its unique domain ID), i.e. all switches run the same zoning configuration.

André

0 Kudos
csaglamoz
Contributor
Contributor

I checked all (fabric,uroute,lsl) seems true. Here is it's output below:

FabricA:

NSmasterUst:FID128:root> fabricshow

Switch ID   Worldwide Name           Enet IP Addr    FC IP Addr      Name

-------------------------------------------------------------------------

  1: fffc01 10:00:50:eb:1a:42:6c:c4 10.9.68.21      0.0.0.0        >"NSmasterUst"

  3: fffc03 10:00:50:eb:1a:42:6d:f4 10.9.68.23      0.0.0.0         "NSdort"

  5: fffc05 10:00:50:eb:1a:42:21:d0 10.9.68.25      0.0.0.0         "NSiki"

The Fabric has 3 switches

Fabric Name: NS1

NSmasterUst:FID128:root> urouteshow

Local Domain ID: 1

In Port    Domain    Out Port    Metric    Hops    Flags    Next (Dom, Port)

----------------------------------------------------------------------------

   0          3          1         500       1       D            3,25

              5         45         500       1       D            5,27

NSmasterUst:FID128:root> islshow

  1:  1-> 25 10:00:50:eb:1a:42:6d:f4   3 NSdort          sp:  8.000G bw: 48.000G TRUNK CR_RECOV

  2: 45-> 27 10:00:50:eb:1a:42:21:d0   5 NSiki           sp:  8.000G bw: 48.000G TRUNK CR_RECOV

FabricB:

NSmasterAlt:FID128:root> fabricshow

Switch ID   Worldwide Name           Enet IP Addr    FC IP Addr      Name

-------------------------------------------------------------------------

  2: fffc02 10:00:50:eb:1a:42:7f:24 10.9.68.22      0.0.0.0        >"NSmasterAlt"

  4: fffc04 10:00:50:eb:1a:42:95:10 10.9.68.24      0.0.0.0         "NSuc"

  6: fffc06 10:00:50:eb:1a:42:8c:7c 10.9.68.26      0.0.0.0         "NSbir"

The Fabric has 3 switches

Fabric Name: NS1

NSmasterAlt:FID128:root> urouteshow

Local Domain ID: 2

In Port    Domain    Out Port    Metric    Hops    Flags    Next (Dom, Port)

----------------------------------------------------------------------------

   0          4          1         500       1       D            4,24

              6         46         500       1       D            6,29

NSmasterAlt:FID128:root> islshow

  1:  1-> 24 10:00:50:eb:1a:42:95:10   4 NSuc            sp:  8.000G bw: 48.000G TRUNK CR_RECOV

  2: 46-> 29 10:00:50:eb:1a:42:8c:7c   6 NSbir           sp:  8.000G bw: 48.000G TRUNK CR_RECOV

0 Kudos
a_p_
Leadership
Leadership

Would you mind to run the zoneshow commend on each of the switches to see whether they show the same effective configuration within each fabric?


André

0 Kudos
csaglamoz
Contributor
Contributor

Yes they all showes the same. Also I tried to disable all zoning before to test if it is a zone related issue.

0 Kudos
Pure_Scott
Contributor
Contributor

I am looking at a similar issue and was wondering what the resolution would be for this thread.  Any insights?

0 Kudos