SteveM2978
Contributor
Contributor

Host NIC issues after updating

Hi I am hoping someone can assist with an issue I have in VMWare. I have a cluster with 3 esxi hosts in, they are all HP DL380 Gen9 servers and a HP MSA2040 SAN.

The servers are running the following OS all HPE specific images.

ESXi 1 - VMware ESXi, 6.5.0, 5224529

ESXi 2 - VMware ESXi, 6.5.0, 17477841

ESXi 3 - VMware ESXi, 6.5.0, 4564106

ESXi host 2 running VMware ESXi, 6.5.0, 10719125 Was updated yesterday using the HPE specific image, however after the update the host failed to boot up esxi properly. I now get an error that says..

------Anunexpected error occurred-----

See logs for details

Exception .HandledError: Error (see log for more info)

There was a problem with the Network Device specified on the command line. Error: No NIC found with MAC address “8c:dc:xx:Xx:Xx”

This NIC is a HP Ethernet 10GB 2 Port 530SFP+ Adapter with Firmware version 7.18.69. This is identical to the version running on Host 1, which although is on a lower level OS is working as expected. Host 3 however is running a slightly different version (bc 7.15.77).

For my physical NICs for the fiber ports I am using the bnx2x drivers.

 

0 Kudos
6 Replies
e_espinel
Expert
Expert

Hello.
Check the driver, its version and firmware of the NIC with problems.
esxcli network nic list
esxcli network nic get -n vmnicX

X is the number of the vmnic from which we need the information.
Please attach the results in the post


I found this Advisory from the manufacturer HP, take a look at it.

https://support.hpe.com/hpesc/public/docDisplay?docId=a00090913en_us&docLocale=en_US

 

Enrique Espinel
Senior Technical Consultant IBM, Lenovo and VMware.
VMware VSP-SV 2018, VTSP-SV 2018 VMware Technical Solutions Professional Hyper-Converged Infrastructure (VTSP-HCI 2018)
VMware Technical Solutions Professional (VTSP) 4 / 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
0 Kudos
SteveM2978
Contributor
Contributor

Hi,

Thanks you are almost there I think...

I have got things working again by using shift and R during boot and  moving back to previous version. it would appear that the bnx2x driver isn't in the image. why, I do not know. 

I read that you can bake drives in to the image so I think that that is what I will work on next.

All 3 hosts were updated using the same 2020 SPP pack from HP, there is a new 2021 version out with a couple of small changes. I installed this on one of the hosts and eventually using VUM I have managed to get one host up to the latest version.

 

will be doing these over the coming days to get them all to the same firmware versions.

I still dont know why or what the process is for upgrading. why its failing from USB, failing from Offline Bundle. regardless of U1, U2 or U3. here is a snip from the update log when i tried via a USB

2021-06-16T12:09:17Z esxupdate: 149142: imageprofile: DEBUG: VIBs {'VMware_bootbank_vsanhealth_6.5.0-1.47.7823009'} are replaced by VIB VMware_bootbank_vsanhealth_6.5.0-2.83.12559353, removing them from ImageProfile (Updated) HPE-ESXi-6.
2021-06-16T12:09:17Z esxupdate: 149142: imageprofile: DEBUG: VIB VMware_bootbank_vsanhealth_6.5.0-1.47.7823009 is being removed from ImageProfile (Updated) HPE-ESXi-6.5.0-OS-Release-iso-650.9.6.0.28^@
2021-06-16T12:09:17Z esxupdate: 149142: imageprofile: INFO: Adding VIB VMware_bootbank_vsan_6.5.0-3.149.17127931 to ImageProfile (Updated) HPE-ESXi-6.5.0-OS-Release-iso-650.9.6.0.28^@
2021-06-16T12:09:17Z esxupdate: 149142: imageprofile: DEBUG: VIBs {'VMware_bootbank_vsan_6.5.0-3.138.16576892'} are replaced by VIB VMware_bootbank_vsan_6.5.0-3.149.17127931, removing them from ImageProfile (Updated) HPE-ESXi-6.5.0-OS-Re
2021-06-16T12:09:17Z esxupdate: 149142: imageprofile: DEBUG: VIB VMware_bootbank_vsan_6.5.0-3.138.16576892 is being removed from ImageProfile (Updated) HPE-ESXi-6.5.0-OS-Release-iso-650.9.6.0.28^@
2021-06-16T12:09:17Z esxupdate: 149142: imageprofile: INFO: Adding VIB VMware_bootbank_vsan_6.5.0-3.120.15087173 to ImageProfile (Updated) HPE-ESXi-6.5.0-OS-Release-iso-650.9.6.0.28^@
2021-06-16T12:09:17Z esxupdate: 149142: imageprofile: DEBUG: VIBs {'VMware_bootbank_vsan_6.5.0-3.149.17127931'} replacing VIB VMware_bootbank_vsan_6.5.0-3.120.15087173, removing them from ImageProfile (Updated) HPE-ESXi-6.5.0-OS-Release-
2021-06-16T12:09:17Z esxupdate: 149142: imageprofile: DEBUG: VIB VMware_bootbank_vsan_6.5.0-3.149.17127931 is being removed from ImageProfile (Updated) HPE-ESXi-6.5.0-OS-Release-iso-650.9.6.0.28^@
2021-06-16T12:09:17Z esxupdate: 149142: imageprofile: INFO: Adding VIB VMware_bootbank_vsan_6.5.0-3.157.17299463 to ImageProfile (Updated) HPE-ESXi-6.5.0-OS-Release-iso-650.9.6.0.28^@
2021-06-16T12:09:17Z esxupdate: 149142: imageprofile: DEBUG: VIBs {'VMware_bootbank_vsan_6.5.0-3.120.15087173'} are replaced by VIB VMware_bootbank_vsan_6.5.0-3.157.17299463, removing them from ImageProfile (Updated) HPE-ESXi-6.5.0-OS-Re
2021-06-16T12:09:17Z esxupdate: 149142: imageprofile: DEBUG: VIB VMware_bootbank_vsan_6.5.0-3.120.15087173 is being removed from ImageProfile (Updated) HPE-ESXi-6.5.0-OS-Release-iso-650.9.6.0.28^@
2021-06-16T12:09:17Z esxupdate: 149142: imageprofile: INFO: Adding VIB VMware_bootbank_vsan_6.5.0-3.143.16817310 to ImageProfile (Updated) HPE-ESXi-6.5.0-OS-Release-iso-650.9.6.0.28^@
2021-06-16T12:09:17Z esxupdate: 149142: imageprofile: DEBUG: VIBs {'VMware_bootbank_vsan_6.5.0-3.157.17299463'} replacing VIB VMware_bootbank_vsan_6.5.0-3.143.16817310, removing them from ImageProfile (Updated) HPE-ESXi-6.5.0-OS-Release-
2021-06-16T12:09:17Z esxupdate: 149142: imageprofile: DEBUG: VIB VMware_bootbank_vsan_6.5.0-3.157.17299463 is being removed from ImageProfile (Updated) HPE-ESXi-6.5.0-OS-Release-iso-650.9.6.0.28^@
'^A' is not implemented
0 Kudos
SteveM2978
Contributor
Contributor

just to add, i have tried updateing the NIC in CLI and in VUM and i keep getting the same error on each host.

 

There was an error checking file system on altbootbank, please see log for detail.
Please refer to the log file for more details.

0 Kudos
SteveM2978
Contributor
Contributor

All 3 hosts are now online and running. Host 1 and 3 will not update host 2 is on latest 6.5u3

[root@esxi01:~] esxcli network nic get -n vmnic7
Advertised Auto Negotiation: false
Advertised Link Modes: 10000BaseT/Full
Auto Negotiation: false
Cable Type: FIBRE
Current Message Level: 0
Driver Info:
Bus Info: 0000:08:00.1
Driver: bnx2x
Firmware Version: bc 7.16.3
Version: 2.713.10.v60.4
Link Detected: true
Link Status: Up
Name: vmnic7
PHYAddress: 1
Pause Autonegotiate: false
Pause RX: true
Pause TX: true
Supported Ports: FIBRE
Supports Auto Negotiation: false
Supports Pause: true
Supports Wakeon: false
Transceiver: internal
Virtual Address: 00:50:56:56:04:fc
Wakeon: None

 


[root@esxi02:~] esxcli network nic get -n vmnic7
Advertised Auto Negotiation: false
Advertised Link Modes: 10000BaseT/Full
Auto Negotiation: false
Cable Type: FIBRE
Current Message Level: 0
Driver Info:
Bus Info: 0000:08:00.1
Driver: bnx2x
Firmware Version: bc 7.16.3
Version: 2.713.10.v60.4
Link Detected: true
Link Status: Up
Name: vmnic7
PHYAddress: 1
Pause Autonegotiate: false
Pause RX: true
Pause TX: true
Supported Ports: FIBRE
Supports Auto Negotiation: false
Supports Pause: true
Supports Wakeon: false
Transceiver: internal
Virtual Address: 00:50:56:5a:d3:05
Wakeon: None



[root@esxi03:~] esxcli network nic get -n vmnic7
Advertised Auto Negotiation: false
Advertised Link Modes: 10000BaseT/Full
Auto Negotiation: false
Cable Type: FIBRE
Current Message Level: 0
Driver Info:
Bus Info: 0000:08:00.1
Driver: bnx2x
Firmware Version: bc 7.15.77
Version: 2.713.10.v60.4
Link Detected: true
Link Status: Up
Name: vmnic7
PHYAddress: 1
Pause Autonegotiate: false
Pause RX: true
Pause TX: true
Supported Ports: FIBRE
Supports Auto Negotiation: false
Supports Pause: true
Supports Wakeon: false
Transceiver: internal
Virtual Address: 00:50:56:57:47:2a
Wakeon: None
[root@esxi03:~]

0 Kudos
e_espinel
Expert
Expert

Hello.
try to update the bnx2x driver
attached link from HP

https://support.hpe.com/hpesc/public/swd/detail?swItemId=MTX_6f64d75d2ca14f9290180170b3&swEnvOid=200...

https://support.hpe.com/hpesc/public/swd/detail?swItemId=MTX_b9631f0be28b4898a03bc75cbb&swEnvOid=200...

 

Enrique Espinel
Senior Technical Consultant IBM, Lenovo and VMware.
VMware VSP-SV 2018, VTSP-SV 2018 VMware Technical Solutions Professional Hyper-Converged Infrastructure (VTSP-HCI 2018)
VMware Technical Solutions Professional (VTSP) 4 / 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
0 Kudos
Samanta11
Contributor
Contributor

Fixed by assigning one of the other physical nics the appropriate ip address.

I still do not understand how (what) the windows update did, to have deselected the settings on the first nic.

What are some naming conventions to give to the nics and vethernet nics to have a quick overview on which is which and their functions ?

0 Kudos