Contributor
Contributor

HomeLab with Vmware ESXI and GPU passtrough

Hi there,
This is my first trip to this forum, and i am quite new to vmware ESXI.
What i am trying to do is creating a lab computer with one guestOS with GPU passthrough, but i have some issues and was hoping for some help.

My build is as following

CPU: Intel® Core™ i7-6700K Processor (8M Cache, up to 4.20 GHz) Product Specifications

Motherboard: Asus Z170-A https://www.asus.com/no/Motherboards/Z170-A/

GPU: GeForce GTX1060 (MSI) GeForce GTX 1060 GAMING X 6G | Graphics card - The world leader in display performance | MSI Global

After what i have been able to dig up this setup should be compatible with IOMMU and VT-X/VT-D. I have read that passing trough a consumer
card like the 1060 can be difficult duo to Nvidia blocking this for their consumer cards, but also that it should be possible tricking by editing the conf with hypervisor.cpuid.v0 = "FALSE".

After trying a failing a lot i have managed to get the gpu visible in the guestOS, but i only get error (43). I have tried upgrading the BIOS, the guest OS and installing the latest driver. I also tried with both the ESXI version 5.5 and 5.7. The last test i was not able to enable "IOMMU" on the CPU however, and got an error saying there was something wrong or the hardware was not supported.

Anyone got any suggestions, or is this not possible for this setup?

0 Kudos
1 Reply
Contributor
Contributor

I have found the error 43 to be related to the GPU left in a state that the driver doesn't like.  Usually it works better when ESXI host is freshly booted and get the driver installed.  Before you shutdown/restart your Windows VM you have to disable the GPU in Device Manager and then re-enable after restart.  For me I just had to create a startup/shutdown policy to enable/disable automatically and it has been working fine for me.  It may take a little bit of work to get it going but this process works consistently for me.

-m

0 Kudos