Digitalmeesh
Contributor
Contributor

High memory usage alert after upgrading to vSphere 6

Last night I upgraded my last ESX host from vSphere 5.5 to vSphere 6 update 2 + patches.

Ever since updating the VMware tools on my SQL server VM, I have been getting a "high virtual machine memory usage" alert constantly.  If I look at the guest, I see usage in the 24-25 GB range, with a little more on standby, but that only gets us to about 95%.  However on the VM Host charts and VM Summary, the memory has been shown as pegged at the max allocated to the VM: 32 GB.  I have attached screen shots.  Prior to the upgrade, it obviously didn't do this.  The active memory monitor was never accurate but also never pegged at the max.

Any advice or interpretation for this?

Thanks,

- Michelle

15 Replies

needed more info: are you only facing issue with one VM or even for all other VMs? can you check whether you have over provisioned  VMs memory?  share us the esxtop memory counters. FYI: TPS is not enabled by default as of ESXi 6.0 where it was enabled in 5.5 before U3 patches.

0 Kudos
Digitalmeesh
Contributor
Contributor

Thank you for following up.   This is only affecting the one SQL server VM, no other alarms.  The host has 256 GB of memory and averages only about 26% usage for the last month.  There is no ballooning activity shown on the host or VM.  The VM's reservation is set equal to the assigned memory.  As for TPS, I don't know if it would have been coming into play before, but these are the settings currently on the host:

Mem.ShareScanSize: 4

Mem.ShareScanTime: 60

Mem.ShareforceSalting: 2

Mem.ShareRateMax: 1024

Is this what you are looking for on the esxtop results?

VMMemory4.JPG

Thank you,

Michelle

0 Kudos
Digitalmeesh
Contributor
Contributor

There has been no change in the status, the alert is still showing.  Any recommendations?

Thanks,

- Michelle

0 Kudos
Dee006
Hot Shot
Hot Shot

Have you try to change the memory reservation to unlimited in the VM?

0 Kudos
Digitalmeesh
Contributor
Contributor

The "Limit" setting is already set to unlimited.  The Reservation is set to "Reserve all guest memory", so the full 32 GB is reserved.  It's as though the VM thinks it is using more than the reservation, although looking at the memory in the guest OS, it's not reached the max.

0 Kudos
MrSqR
Contributor
Contributor

After upgrade vsphere from 6.0 to 6.5 VMs with all memory reservation (nvidia grid VM) show memory alarms.

VMware tools was updated, but vHW don't.

This is Horizon VDI VMs.

Anybody know how to fix that?

0 Kudos
estanev
Enthusiast
Enthusiast

Same issue here, few VMs with "Virtual machine memory usage" status RED, thus vROPs memory usage graphic is showing 97-98% constant usage, while the OS resource manager is reporting 38-50%. We recently upgraded to vSphere 6.5.

0 Kudos
TechMassey
Hot Shot
Hot Shot

I have the same issue with ESXi 6.5 and vGPU, according to Nvidia/VMware this will be resolved in a future update. For now, I was forced to disable memory alerts within our Horizon View vGPU deployment.


Please help out! If you find this post helpful and/or the correct answer. Mark it! It helps recgonize contributions to the VMTN community and well me too 🙂
0 Kudos
kblaster
Contributor
Contributor

We are currently having the same issue, any news on a fix?

0 Kudos
Schroeber
Enthusiast
Enthusiast

ESXi 6.5 has a bug that over-reports memory utilization.

VM memory usage heuristic over-reporting on ESXi 6.5 (2149496) | VMware KB

It's supposed to be fixed in Update 1.  If you haven't updated yet, give it a shot and see if it helps.

0 Kudos
matteoabrile
Enthusiast
Enthusiast

Hello,

I have 6.5U1 with NVIDIA and have same issue, wait for update to solve.

Thanks

M.

0 Kudos
estanev
Enthusiast
Enthusiast

Yup 6.5U1 fixed it here.

0 Kudos
Erossman
Enthusiast
Enthusiast

But it's not fixed if your VM is running with Nvidia vGPU and your memory is 100% reservered.

We use ESX 6.5 Build 7388607 and the recent nvidia vib driver (version 5.2).

0 Kudos
Greg_Butler
Contributor
Contributor

Yup. Same issue here. ESXI 6.5 Build 7388607 and same issue as you, Erossman. Did you find a fix?

0 Kudos
Erossman
Enthusiast
Enthusiast

There seems no fix avaiable. As a workaround I did the following.

Disable the high memory alert definition on the vcenter object.

So that this alarm is complete disabled for all object. Then create a new object on the folder object where you want this alert.

All subfolder and subobject will inherit this alert definition. You cannot exclude subfolder/vms when you the define alert definition on the top folder.

I have to do the same for the cp-parent vms which will be generated in an horizon instand clone pool. VMware is not able to provide a fix to exclude these vm's.

It's not the best solution because it can be that you have create this alert definition multiple times for different folder object and the alert is disable for you vGPU vm's.