nitzerebbs
Contributor
Contributor

Hardware Status Alerts - Unconfigured Disk : Disk Error HPSA

Hi,

I am running a single ESX Host 7.0 U1 (HP Microserver Gen10 plus) with HPE E208i-p SR on 4x 2TB SSDs (single lun).

I am getting many hardware errors with unconfigured disks, system runs normal: 

ESX_Error.jpg











I also tried searching for any help, but all infomation is based on older ESX versions...
Does someone have a solution for this ? 

Thanks 

Jan

 

Labels (1)
  • Hi

0 Kudos
35 Replies
e_espinel
Expert
Expert

Hello
It is generally recommended to install VMware vSphere with the manufacturer's custom ISO image in this case HPE which includes manufacturers own drivers and tools.
Most manufacturers provide tools to manage their disk controllers in VMware from CLI.
Attached links

https://itsimple.info/?p=1732

:https://support.hpe.com/hpesc/public/swd/detail?swItemId=MTX-ecd489e042ff4821b90abdd305#tab3

You may need to install the indicated Tools.

 

Enrique Espinel
Senior Technical Consultant IBM, Lenovo and VMware.
VMware VSP-SV 2018, VTSP-SV 2018 VMware Technical Solutions Professional Hyper-Converged Infrastructure (VTSP-HCI 2018)
VMware Technical Solutions Professional (VTSP) 4 / 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
0 Kudos
nitzerebbs
Contributor
Contributor

Thank you for the answer, but of course, I used the HPE custom VMware ISO - that is not the problem.

 

0 Kudos
nitzerebbs
Contributor
Contributor

I did several checks now with the HPE Smart Storage Administrator CLI, and everything is ok, there are absolutely no errors.

 

0 Kudos
e_espinel
Expert
Expert

Hello.
If from the HPE Smart Storage Administrator CLI no error was found, we are fine physically.
You should check if the current firmware of the controller and disks, has no problems reported in HPE, or if there is a higher or recommended level to upgrade.
Another point to check is the version of the driver you are using for the disk controller, if there is a higher level it is recommended to update it.
Please read all the requirements before upgrading either the firmware or the driver.
Always have a full backup of the data (VMs) and the ESXi configuration.

The following commands will help you identify the controller and driver you are using.

# esxcli storage core adapter list

Run this command to get get the specifics of the device driver

# vmkload_mod -s HBADriver |grep Version

# esxcli software vib list | grep HBADriver

 

Enrique Espinel
Senior Technical Consultant IBM, Lenovo and VMware.
VMware VSP-SV 2018, VTSP-SV 2018 VMware Technical Solutions Professional Hyper-Converged Infrastructure (VTSP-HCI 2018)
VMware Technical Solutions Professional (VTSP) 4 / 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
0 Kudos
nitzerebbs
Contributor
Contributor

Hi, no new firmware available for the controller, because I am already using V 3.53.

Maybe I try using the drivers from ESX 7.0U2a for "smartpqi", this is newer than my actual one:
old: 70.4000.0.100-4vmw.701.0.25.17325551
new: 70.4000.0.100-6vmw.702.0.0.17867351

I don't know if this is a solution...

No one else having these kind of alerts ?

0 Kudos
nitzerebbs
Contributor
Contributor

Hi, no new firmware available for the controller, because I am already using V 3.53.

Maybe I try using the drivers from ESX 7.0U2a for "smartpqi", this is newer than my actual one:
old: 70.4000.0.100-4vmw.701.0.25.17325551
new: 70.4000.0.100-6vmw.702.0.0.17867351

I don't know if this is a solution...

No one else having these kind of alerts ?

0 Kudos
kevinw9521
Contributor
Contributor

Hello,

 

i have the same problem  i am running  HPE Customized ESXi 7.0.2 Image version 702.0.0.10.6.3 for HPE Servers based on VMware ESXi 7.0.2 release.with the newest Service Pack Prolian installed (2021 )

 

(HPE-Custom-AddOn_702.0.0.10.6.3-24 (Hewlett Packard Enterprise))

 

 

0 Kudos
MauAnd
Contributor
Contributor

Hello,

I have the same problem on two new servers with the latest version of Esxi "VMware-ESXi-7.0.2-17867351-HPE-702.0.0.10.7.0.52".

0 Kudos
nitzerebbs
Contributor
Contributor

seems to be a general problem, which controllers are you guys using ?

0 Kudos
MauAnd
Contributor
Contributor

I use the HPE P408i-a SR Gen10.

In addition I have a third server with similar configuration but the problem is not present.

1. Server Dl360 Gen10 - 3 hd sas 1.8tB - 3 hd sata ssd - Has the problem
2. Ml350 Gen 10 Server - 3 hd sas - 3 hd sas ssd - Has the Problem
3. Ml350 Gen 10 Server - 3 hd sas - Doesn't Have The Problem

I am not sure, but Server 2 with the two sas ssd disks up to last week did not have the problem, I doubt that the problem is activated when adding ssd disks.
But as said I'm not sure

 

0 Kudos
e_espinel
Expert
Expert

Hello
According to the VMware compatibility matrix (online) for the HPE Smart Array E208i-p SR Gen10 with Firmware 3.53,
VMware ESXi 7.0 smartpqi 70.4054.2.118 driver is required.
https://www.vmware.com/resources/compatibility/detail.php?deviceCategory=io&productid=43646

e_espinel_0-1621427366969.png

Download driver from https://my.vmware.com/en/web/vmware/downloads/details?downloadGroup=DT-ESXI70-MICROSEMI-SMARTPQI-704...

How to download and install async drivers in VMware ESXi (2005205)

https://kb.vmware.com/s/article/2005205

 

Enrique Espinel
Senior Technical Consultant IBM, Lenovo and VMware.
VMware VSP-SV 2018, VTSP-SV 2018 VMware Technical Solutions Professional Hyper-Converged Infrastructure (VTSP-HCI 2018)
VMware Technical Solutions Professional (VTSP) 4 / 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
0 Kudos
nitzerebbs
Contributor
Contributor

does anyone have the possibility to try the required driver, maybe in a test environment?

For me it is only possible with a downtime, and if it does not help, it's a waste of time...

0 Kudos
MauAnd
Contributor
Contributor

Hi, I have tried on the server that I am preparing,
I don't have the "HPE Smart Array E208i-p SR Gen10 with Firmware 3.53" controller but the "HPE P408i-a SR Gen10 3.53" the driver present is the same as the one I'm downloading.

[root@localhost:~] esxcli software vib install -d /vmfs/volumes/datastore1/App/drv.zip
Installation Result
Message: Host is not changed.
Reboot Required: false
VIBs Installed:
VIBs Removed:
VIBs Skipped: MIS_bootbank_smartpqi_70.4054.2.118-1OEM.700.1.0.15843807

[root@localhost:~] esxcli software vib list |grep smart
smartpqi 70.4054.2.118-1OEM.700.1.0.15843807 MIS VMwareCertified 2021-05-19

0 Kudos
nitzerebbs
Contributor
Contributor

Thank you...
...so the required driver does not fix the problem ☹️

0 Kudos
MauAnd
Contributor
Contributor

unfortunately not

0 Kudos
e_espinel
Expert
Expert

Hello.
First if we change server to test the driver, let's know which driver is using the controller of that server.

This command lists the adapters and their drivers, we are going to assume that it uses the same smartpqi driver, but you should verify that it does.
# esxcli storage core adapter list

This command tells us which driver is loaded i.e. in use
# vmkload_mod -s smartpqi |grep Version

This command tells us which vib or vibs are installed, they can be of different versions, but only one is the one in use
# esxcli software vib list | grep smartpqi 

or

# esxcli software vib list | grep smart

The VIBs Skipped: means that it was not installed, so the message is clear Message: Host is not changed

Whenever a driver is installed or updated, a reboot will be required.

 

Enrique Espinel
Senior Technical Consultant IBM, Lenovo and VMware.
VMware VSP-SV 2018, VTSP-SV 2018 VMware Technical Solutions Professional Hyper-Converged Infrastructure (VTSP-HCI 2018)
VMware Technical Solutions Professional (VTSP) 4 / 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
0 Kudos
sponsz
Contributor
Contributor

Hello,

i have the same error on multiple DL385 Gen 10 Plus servers on a new working vSAN cluster.

VMware ESXi 7.0.2 Build-17867351 Update 2
HPE Customization for HPE Servers 702.0.0.10.7.0-52
HPE Smart Array E208i-a SR Gen10 3.53
System ROM A42 v2.40
iLO Firmware Version 2.44

 

# esxcli storage core adapter list
HBA Name  Driver     Link State  UID                   Capabilities  Description
--------  ---------  ----------  --------------------  ------------  -----------
vmhba0    nvme_pcie  link-n/a    pcie.300                            (0000:03:00.0) Marvell Technology Group Ltd Marvell NR2241 NVMe Controller
vmhba1    smartpqi   link-n/a    sas.51402ec015714e80                (0000:04:00.0) Microsemi HPE E208i-p SR Gen10
vmhba2    smartpqi   link-n/a    sas.51402ec01640a970                (0000:64:00.0) Microsemi HPE E208i-a SR Gen10
vmhba3    nvme_pcie  link-n/a    pcie.2300                           (0000:23:00.0) Samsung Electronics Co Ltd NVMe SSD Controller PM173X
vmhba4    nvme_pcie  link-n/a    pcie.2500                           (0000:25:00.0) Samsung Electronics Co Ltd NVMe SSD Controller PM173X
vmhba5    nvme_pcie  link-n/a    pcie.2600                           (0000:26:00.0) Samsung Electronics Co Ltd NVMe SSD Controller PM173X

# vmkload_mod -s smartpqi |grep Version
Version: 70.4054.2.118-1OEM.700.1.0.15843807

# esxcli software vib list | grep smartpqi 
smartpqi                       70.4054.2.118-1OEM.700.1.0.15843807  MIS      VMwareCertified   2021-05-15
lsuv2-smartpqiv2-plugin        1.0.0-6vmw.702.0.0.17867351          VMware   VMwareCertified   2021-05-15

 

 

I would like to try FW 3.00 but where can get smartpqi 70.4000.0.100-6vmw.702 which is mentioned here https://www.vmware.com/resources/compatibility/detail.php?deviceCategory=vsanio&productid=41773&devi...

Could the attached drives cause that problem? I have 9x VO007680JWZJL with FW HPD4 per server. https://www.vmware.com/resources/compatibility/detail.php?deviceCategory=ssd&productid=46362&deviceC...

 

 

0 Kudos
e_espinel
Expert
Expert

Hello.
I have checked HPE for the latest Firmware and Driver levels for the Smart Array controllers, and there are no more. But if entering through the HPE Smart Storage Administrator CLI no errors are found, then physically there is no problem.
We will have to wait for new drivers or Firmware to be generated to correct this false positive.Or maybe some magic trick to solve it.

Personally I am not in a hurry to move to version 7, most of my customers are on version 6 comfortably.

 

Enrique Espinel
Senior Technical Consultant IBM, Lenovo and VMware.
VMware VSP-SV 2018, VTSP-SV 2018 VMware Technical Solutions Professional Hyper-Converged Infrastructure (VTSP-HCI 2018)
VMware Technical Solutions Professional (VTSP) 4 / 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
0 Kudos
MauAnd
Contributor
Contributor

Hello,
as information I also tested the
ESXi 6.7 U3 May 2021 - Support Gen9 Servers and forward.
But even with this version the problem arises.
I haven't checked with previous versions.

Greetings, have a nice day.

0 Kudos