Pircs
Contributor
Contributor

Fix Wrong Source Interface for Wake on Lan Packets

In my lab setup I am using two ESXi 6 hosts and the VCSA. I have setup VLANs for iSCSI, vMotion, and Management.

iSCSI is using the non wake-on-lan ports and vMotion the wake-on-lan ports.

When I place an ESXi host on standby this functions normally. When I select to Power On the standby host the host does not power on.

I captured packets on the network and discovered that the active ESXi host is sending the Wake-On-Lan packets from the iSCSI interface. So the wake up fails because the iSCSI VLAN does not connect to any ports of the standby host which are capable of wake-on-lan. Also the MAC addresses for the wakeup packets are not on the iSCSI VLAN; they are on the vMotion and Management VLANs.

Is it possible to fix this behavior and force the active ESXi host to send the wake up packet out the vMotion or Management interface so the packets will reach a wake-on-lan port of the standby host?

Tags (2)
0 Kudos
2 Replies
bio
Enthusiast
Enthusiast

Did you try to play with the CLI?

esxcli network nic list

esxcli network nic get -n <NICname>    <--- Here you can find WOL settings etc..

esxcli network nic get -n <NICname> -w=<option.            <---- -w = WLAN option


regards

richard

__________________________________________________________ If you find an answer that helps you, please mark it as "correct" or "helpful".
0 Kudos
Pircs
Contributor
Contributor

Yes, these commands show that

Supports Wakeon: true and

Wakeon: MagicPacket(tm)

The host will wakeup with Wakeup packets sent from outside of vSphere.

When I finally got this to work; I found that I needed to ensure that the vmk1 interface was poised to perform Wakeup to other hosts because ESXi insists to only use the vmk1 interface for Wakeup. I just ensure that vmk1 has native vlan access to at least one Wake On Lan enabled port of the other host.

Other information that I have read implies that the vMotion interface will always be the source of Wakeup packets but this was not the case in my environment.

0 Kudos