Failing Disk - partedUtil getptbl showing "unknown"

Hi everyone,

I have a failing SATA disk on a home test lab that I'd like to try to save if possible. I have a backup of the data but it's taking forever to download (multiple TB). The drive still spins up and I've already made a backup IMG file of it. I'm hoping to use the original disk if possible because I'm not 100% confident in the image file since it was made after the drive started failing.

I tried repairing the partition table by using this command:

partedUtil setptbl /dev/disks/t10.ATA_____ST1000DM0032D1CH162__________________________________S1D6RL5G gpt "1 2048 1953525168 AA31E02A400F11DB9590000C2911D1B8 0"

Apparently that effort failed because when I run the following command on the disk:

partedUtil getptbl /vmfs/devices/disks/vml.010000000020202020202020202020202053314436524c3547535431303030

I get:


121601 255 63 1953525168

I know the partition table was previously GPT and the filesystem was VMFS from a 6.5 U2 system (I'm using the same system for recovery). Any chance of recovering my data using the original drive?

0 Kudos
1 Reply

I highly recommend to no longer work with the original drive.

The images you created should be used for any further reading attempts.

And you should check your images as soon as possible to find out if they are usable.

I hope you create the backups with ddrescue ?
If you need help with extracting any data from either the original disk or from the images let me know.
For now the most urgent question is: how did you create the backup-images ?

Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos