stmux
Enthusiast
Enthusiast

Failed to start the virtual machine after restore

Jump to solution

All Hosts including Test Host: ESXi 5.1.0.1065491

Problem vm: 32 Bit Server 2003

I use Veeam Backup & Restore 6.5 to backup my vm's.  I always do a test restore to make sure my backups are good.  I am having a problem with one restore.  The 32 Bit Server 2003 vm powers up just fine on the main host it runs on.  All of the vm's are 64 Bit except one which is a 32 Bit Server 2003 vm.  All of the vm's restore and power up on a test host except the 32 Bit Server 2003 vm.  After restoring and trying to power up I get the following error:

Failed to start the virtual machine.

Module VPMC power on failed.

Virtualized performance counters require architectural performance monitoring version 3 or greater.

Does anyone know if there is a fix for this problem?

TIA,

mux

1 Solution

Accepted Solutions
a_p_
Leadership
Leadership

I assume you use different hardware (CPUs, BIOS settings) for the restored VMs!?

The VM has vPMC enabled, which causes the issue. You can either disable it in vSphere Web Client (you can't do this in the Windows vSphere Client) or direcly edit the VM's .vmx file by setting vpmc.enable to "FALSE".

For how to enable/disable this setting in the Web Client see Enable Virtual CPU Performance Counters in the vSphere Web Client. If you are going to edit the .vmx file manually, you either need to remove/re-add the VM from/to the inventory or reload it (see http://kb.vmware.com/kb/1026043)

André

View solution in original post

4 Replies
a_p_
Leadership
Leadership

Please attach the VM's .vmx file as well as its latest vmware.log to a reply post.

André

Note: To be able to attach files, you need to use the advanced editor.

0 Kudos
stmux
Enthusiast
Enthusiast

Requested files are attached.

0 Kudos
a_p_
Leadership
Leadership

I assume you use different hardware (CPUs, BIOS settings) for the restored VMs!?

The VM has vPMC enabled, which causes the issue. You can either disable it in vSphere Web Client (you can't do this in the Windows vSphere Client) or direcly edit the VM's .vmx file by setting vpmc.enable to "FALSE".

For how to enable/disable this setting in the Web Client see Enable Virtual CPU Performance Counters in the vSphere Web Client. If you are going to edit the .vmx file manually, you either need to remove/re-add the VM from/to the inventory or reload it (see http://kb.vmware.com/kb/1026043)

André

stmux
Enthusiast
Enthusiast

I set VPMC=False and the vm booted right up.   Looks like all the backups are solid.   Thankyou Andre

mux

0 Kudos