Failed to Upgrade ESXi 5.1 to ESXi 5.5

Hi all,

This is my first time to post a question.

I want to upgrade ESXi 5.1 to 5.5.

After boot with DVD ESXi 5.5 standard, and proceed with some confirmation dialogues. There are 3 choices:
(X) Upgrade ESXi, preserve VMFS datastore

( ) Install ESXi, preserve VMFS datastore

( ) Install ESXi, overwrite VMFS datastore

So, I choose "Upgrade ESXi, preserve VMFS datastore".

And after that, the process is going until it stuck at 24% progress for 15 minutes, with error message:

AttributeError: 'NoneType' object has no attribute 'AddVibs'

(Please see my attachment about this, with file name of "Progress-was-stuck-in-24-percent.png" and "AttributeError.png".)

After another minutes, the screen was go back to the confirmation dialogue, this time with only 2 choices:

( ) Install ESXi, preserve VMFS datastore

( ) Install ESXi, overwrite VMFS datastore

(Please see my attachment, with file name "No-upgrade-option.png")

Summary of this post:
Physical Server Type: HP Proliant ML310e Gen8 Server (Tower type)

Processor: Intel(R) Xeon(R) CPU E3-1230 V2 @3.30GHz

BIOS Version: J04 Release Date 10/12/2012 12:00:00 AM

HP Server Warranty Contract: Expired

ESXi License: VMware vSphere 5 Essentials - Licensed for 1 physical CPUs (unlimited cores per CPU, Expires: Never)

VMware Support Contract: I don't have it

Current ESXi version: ESXi-5.1.0-20130402-001-standard

ESXi 5.5 image profile: VMware-VMvisor-Installer-5.5.0.update01-1623387.x86_64.iso

Error message when tried to upgrade: AttributeError: 'NoneType' object has no attribute 'AddVibs'

Have anyone experienced the same problem like this?
Can somebody help me?

Thank you,


0 Kudos
5 Replies
Hot Shot
Hot Shot

0 Kudos

Hi viho,

I think ESXi 5.1 standard installation should only be upgraded by ESXi standard image, right?

And HP customized ESXi installation should only be upgraded by HP ESXi customized image, right?

0 Kudos


have you installed any custom VIBs into your 5.1 image because this failure can happen if these VIBs are not included in installation ISO during upgrade...?!

To identify HP custom VIBs run this command:

esxcli software vib list | grep HP  or Hewlett

Also verify your firmware builds with smbiosDUMP command and try to apply the latest if you have older:


Power Controller


Message was edited by: vNEX

_________________________________________________________________________________________ If you found this or any other answer helpful, please consider to award points. (use Correct or Helpful buttons) Regards, P.
0 Kudos
Hot Shot
Hot Shot

  • You cannot upgrade the ESXi/ESX host software.
  • Upgrading the ESXi/ESX host software fails.
  • The ESXi/ESX host software upgrade fails to complete.
  • Unable to complete the ESXi/ESX host software upgrade.
  • If the host was upgraded from ESXi/ESX 3.5 to 4.x, while performing a scan during an upgrade to ESXi 5.0 or ESXi 5.1, the VMware Update Manager events tab reports this error:
    incompatible with esx.cfg file

Validate that each troubleshooting step below is true for your environment. Each step will provide instructions or a link to a document, for validating the step and taking corrective action as necessary. The steps are ordered in the most appropriate sequence to isolate the issue and identify the proper resolution. Please do not skip a step.

  1. Verify that the ESXi/ESX version upgrade path requirements  are met. For more information, see the Release Notes for your version of ESXi/ESX.
  2. Verify that the minimum system requirements for installing ESXi/ESX are met. For more information, see Minimum system requirements for installing ESXi/ESX (1003661).
  3. Verify that the hardware on which you are trying to install is certified. For more information, see Confirming ESX/ESXi host hardware (System, Storage, and I/O) compatibility (1003916).
  4. Verify if the issue is cause by the upgrade media. For more information, see Checking media integrity for ESX/ESXi host installations or upgrades (1003674).
  5. Verify that your hardware is working as expected. For more information, see Verifying your hardware is functioning correctly (1003690).
  6. Verify that you have adequate disk space to complete the installation. For information, see Investigating disk space on an ESX or ESXi host (1003564).
  7. Verify that your firmware and BIOS are at the latest revision. For more information, see Checking your firmware and BIOS levels to ensure compatibility with ESX/ESXi (1037257).
  8. If a failed upgrade has left your server in an inconsistent state, so that a reinstall also fails, you may need to perform a clean installation. For more information, see Completing a clean installation using the ISO image if your installation or upgrade fails of ESX/ESX....
0 Kudos


I have experienced the exact same problem when trying to remediate one of my HP DL380p Gen 8 Rackmount Hosts.

VMware Update Manager was throwing the following error in the vSphere Cient:

The host returns esxupdate error code:15.

The package manager transaction is not successful.

Check the Update Manager log files and esxupdate log files for more details.

When I looked at the esxupdate.log on the Host I could see the following lines:

2015-09-22T15:15:15Z esxupdate: HostImage: DEBUG: Live image has been updated but /altbootbank image has not.  This means a reboot is not safe.

2015-09-22T15:15:15Z esxupdate: imageprofile: INFO: Adding VIB VMware_locker_tools-light_5.0.0-3.68.2509828 to ImageProfile (Updated) HP-ESXi-5.0.2-standard-iso

2015-09-22T15:15:15Z esxupdate: HostImage: DEBUG: Live image has been updated but /altbootbank image has not.  This means a reboot is not safe.

The Funny thing is that it has worked flawlessly on the second Host in the Cluster which is the exact same server model.

I tried with to fix this with an Update Manager Expert in the VMware Support Organisation, but there was no way to fix it.

It seems that the whole Image Profile on the Host has disappeared!

you can see this by running the command "df -h" and look at the fist vFat Partition in the list and compare this with your other Hosts:

Filesystem    Size             Used      Available        Use%       Mounted on

vfat               249.7M         1.5M        248.2M             1%       /vmfs/volumes/08f4f5e0-5b7b00c2-8a0f-0504b88f0c3c

vfat               249.7M     169.3M          80.4M           68%       /vmfs/volumes/5d59c6eb-b0cee482-c196-37c9b0d08443

vfat               285.8M     195.9M          89.9M           69%       /vmfs/volumes/51137f0c-c41939f3-2648-ac162d727eb5

It is basically empty!

When I run a "esxcli software profile get" I get the following output:


No host image profile defined

Please refer to the log file for more details.

When I run a "esxcli software vib list" I get only the VMware-Tools-Light vib displayed:

Name         Version             Vendor  Acceptance Level  Install Date

-----------  ------------------  ------  ----------------  ------------

tools-light  5.0.0-3.68.2509828  VMware  VMwareCertified   2015-08-18

Today I tried an Upgrade using the látest HP Custom Image for ESXi 5.0 Update 3


It furst detects the local SD-Card and after a scan detects that the Host is upgradable and offeres the "Upgrade" Option.

When I select "upgrade" and press Enter to continue I get the "Confirm Upgrade" Screen displayed and I can stat the upgrade with "F11".

When I do that the process starts, but stops at 24 percent with a cryptical error code and the message:

AttributeError: ‚NoneType‘ object has no attribute ‚AddVibs‘


VMware Support has no solution for this problem.

Looks like i will have to re install the Host from scratch.

0 Kudos