SAAM_IT
Contributor
Contributor

FC Datastore showing not consumed

We have 3 HP DL 380 servers running ESXi 6.0 accessing two FC directly connected Lun's on a MSA 2050. One of the Lun is visible on all three esxi's and working fine but the other is showing as not consumed on all three servers. This issue came when we replaced one faulty controller on MSA 2050. 

From the MSA end, the pools and the disk groups are healthy, do not see any issues. but from VMkernel logs, it is showing 

2020-12-30T11:43:43.950Z cpu0:33524)ScsiDeviceIO: 2652: Cmd(0x43b600ec5040) 0x89, CmdSN 0x3 from world 33272 to dev "naa.600c0ff00044199e83cc255e01000000" failed H:0x0 D:0x2 P:0x0 Valid sense data: 0x5 0x20 0x0.

2020-12-30T11:43:43.950Z cpu1:33272)LVM: 13756: Failed to open device naa.600c0ff00044199e83cc255e01000000:1 : Not supported

How can i fix this?

Thanks

 

Tags (2)
0 Kudos
3 Replies
scott28tt
VMware Employee
VMware Employee

@SAAM_IT 

Something else that is “not supported” is ESXi 6.0 itself, if you run anything like production workloads you should consider upgrading to at least 6,5.

0 Kudos
SAAM_IT
Contributor
Contributor

@scott28tt Yes, you are right. but i need to fix the issue with the current version. I will do the upgrade after getting approval.

All the VM's on the datastore are down right now and I have tried to scan the adaptors, still it is showing as Not Consumed. 

 

Thanks.

 

0 Kudos
a_p_
Leadership
Leadership

What you may check is whether the LUN is recognized as a "Snapshot LUN", i.e. has a known signature, but is seen on another device.
To find out about this, please see the "Command line" section at https://kb.vmware.com/s/article/1011387
In case it's detected as a snapshot LUN, the KB article also contains commands to mount the LUN again.

André

0 Kudos