VMware Cloud Community
CantonKen
Contributor
Contributor

Esxi host does not respond to ping

Hi all,

I am trying to set up learning lab with ESXi.  I loaded esxi 6.5 and assigned static address.

I can ping the address: 192.168.1.72 which is the host.

If I ping the name Home150 it is unable to find the host.

mask is 255.255.255.0  with both dns and gateway are 192.168.1.254

ESX lists the domain as Home150.home.com but win I ping home.150.home com it returns 23.217.138.110

I can ping other computers on the network 192.168.1.xxx by name.

The dns extension lists adding  attlocal.net.

What am I missing?

If this is not the right spot, please point me to the correct location.

thanks

Kenu

Tags (1)
Reply
0 Kudos
5 Replies
daphnissov
Immortal
Immortal

The domain home.com is an already registered domain on the public internet. For internal lab environments, your domain should not conflict with something on the Internet by using a TLD such as .local instead. Do you have a local DNS server responding to queries at 192.168.1.254? If not, when you attempt to ping that record there's nothing to find locally so it goes out to DNS servers on the Internet. You'll either need a local DNS server at that address with a zone for home.com, or a static entry in your hosts file that is able to map that name to the IP of your host.

Reply
0 Kudos
NathanosBlightc
Commander
Commander

Scenario1: Change the DNS suffix and add another domain name that is not a public registered domain name. Using words like .internal or .local . Also, you must add this suffix name to your client to resolve the ESXi host's name (easy way)

Scenario2: Install a local DNS server that is responding to the home.com in your local network (better way)

Scenario3: Add the FQDN of your ESXi host and its IP address to the c:\windows\system32\drivers\etc\hosts in your client system (dummy way)

Please mark my comment as the Correct Answer if this solution resolved your problem
Reply
0 Kudos
CantonKen
Contributor
Contributor

Ok, I changed esxi host name to brown.color.local

I set a windows computer to a workgroup of color.local

if I try to ping brown.color.local  it still does not resolve.

The vmware vsphere client also does not resolve brown.color.local but will resolve to the ip address.

Hmmm

Reply
0 Kudos
a_p_
Leadership
Leadership

Unless you do have a DNS server, follow NathanosBlightcaller​'s "Scenario3" option.

André

Reply
0 Kudos
T180985
Expert
Expert

You will need a DNS server able to resolve "color.local" or you could manually add each device into your host file so your PC is able to resolve it that way but hardcoding addresses like that will come back to bite you at some point

Please mark helpful or correct if my answer resolved your issue. How to post effectively on VMTN https://communities.vmware.com/people/daphnissov/blog/2018/12/05/how-to-ask-for-help-on-tech-forums
Reply
0 Kudos